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Dear Parent:

At VIech® we know that children have the ability to do great
things. That’s why all of our electronic learning products
are uniquely designed to develop a child’s mind and allow
them to learn to the best of their ability. Whether it's learning
about letters, numbers, geography or algebra, all VIech®
learning products incorporate advanced technologies and
extensive curriculum to encourage children of all ages to reach

their potential.

When it comes to providing interactive products that enlighten,
entertain and develop minds, at VIech® we see the potential

in every child.
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CHAPTER 1 INTRODUCTION

Thank you for purchasing the PRECOMPUTER UNLIMITED™ by VTECH®. We at VTech®
are committed to providing the best products to entertain and educate your child. Should
you have any questions or concerns, please call our Consumer Services Department at
1-800-521-2010.

The PRECOMPUTER UNLIMITED™ turns your TV into a learning computer. The unit comes
equipped with many software applications like a word processor, spreadsheet, art studio,
and programming tutor. What makes the PRECOMPUTER UNLIMITED™ unique is the
integration of all the applications. For example, you can paste pictures drawn in the art
studio into your presentations, or you can use the unit as your database and phone book.
With your creativity the options just keep developing.

LETTER
KEYBOARD OFF BUTTON ON BUTTON

DIRECTIONAL

CURSOR

PAD

RIGHT FIRE NUMBER

BUTTON KEYBOARD LED

Downloaded from www.Manualslib.com manuals search engine


http://www.manualslib.com/

CHAPTER 2 HOOK-UP AND CONNECTION

AC ADAPTOR INSTALLATION

We recommend you use the adaptor (DC

9V === 500mA + -€—— AC adaptor)
which comes with the unit.

1. Make sure the unit is turned OFF.

2. Locate the adaptor jack on the back
of the unit.

3. Plug the adaptor into the unit's adaptor
jack.

4. Plug the adaptor into a wall outlet.
5. Turn the unit ON.

TV HOOK-UP

1. Make sure that both the TV and the
PRECOMPUTER UNLIMITED™ are
OFF.

2. Select either of the connection cables,
they are identical. Plug one end of
the cable into the VIDEO OUT jack
on the back of the PRECOMPUTER
UNLIMITED™ unit.

3. Plug the other end of the cable into
the VIDEO IN jack of the TV.

4. Pick up the unused connection cable.
Plug one end of the cable into the
AUDIO OUT jack of the
PRECOMPUTER UNLIMITED™ unit.

5. Plug the other end of the cable into
the AUDIO IN jack of the TV.

6. Set your TV remote control to
Video(AV) or select AV from the
control panel of the TV.
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VCR HOOK-UP

1. Make sure that the TV, VCR and the PRECOMPUTER UNLIMITED™ are all OFF.
2. Connect your VCR and TV as you normally would.

3. Make sure your VCR is in the Video mode and that the TV channel matches the VCR
output channel.

4. Select either of the connection cables, they are identical. Plug one end of the cable
into the VIDEO OUT jack on the back of the PRECOMPUTER UNLIMITED™ unit.

5. Plug the other end of the cable into the VIDEO IN jack of the VCR.

6. Pick up the unused connection cable. Plug one end of the cable into the AUDIO OUT
jack of the PRECOMPUTER UNLIMITED™ unit.

7. Plug the other end of the cable into the AUDIO IN jack of the VCR.

VIDEO OUT  AUDIO OUT

Oe=. —]

Y ul

AUDIO IN VIDEQ IN

@ VCR J

—_—

PRECOMPUTER UNLIMITED™

VIDEO IN

/
@]
VIDEO CABLE
(INCLUDED)
\ AUDIO IN

MOUSE CONNECTION

1. Make sure the unit is turned OFF. PRECOMPUTER UNLIMITED™

2. Locate the mouse jack on the back of
the unit Ut

3. Plug the mouse into the mouse jack. MOUSE MOUSE JACK
4. Turn the unit ON.

5. Move the cursor on the screen by moving
the mouse in the direction you would like
the cursor to move. The left button on
the mouse functions the same as the
keyboard ENTER key.

AUDIO CABLE (iNCLUDED)
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PRINTER CONNECTION

Locate the printer port on the back of the

. Make sure the unit is turned OFF.

PRECOMPUTER UNLIMITED™ unit.

Plug the printer's data cable into the printer
jack of the PRECOMPUTER UNLIMITED™
unit. Note: a printer cable does not come
with the PRECOMPUTER UNLIMITED™ unit,
you need to use the data cable which came

with your printer.

Make sure the other side of the data cable
is connected to the printer.

5. Turn the unit ON first.

Then turn ON the printer.

PRECOMPUTER UNLIMITED™

| xere DAY

>

PRINTER JACK

POWER LINK™ [NSTALLATION

1.

Start your computer in MS-DOS mode.

PRINTER (NOT
INCLUDED)

2. Insert the floppy disk labeled “POWER LINK™" into your computer’s floppy drive.

3. At the DOS prompt type “A:NINSTALL” then hit Enter.

than the A drive, substitute the appropriate letter for A.)

(If your floppy drive is other

Followthe screen instructions. From here the program should prompt you with questions.

PC AND PRECOMPUTER UNLIMITEDTM
CONNECTION

1.

Make sure the unit and the
PC are OFF.

Select the POWER LINK™
cable from the packed in
materials.

Insert one end of the cable
into the jack labeled “PC
LINK” on the back of the
PRECOMPUTER
UNLIMITED™ unit.

Connect the other end of
the cable into the serial port
of your PC.

PC LINK JACK

Turn the unit and the PC ON.
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PRECOMPUTER UNLIMITED™ AND PRECOMPUTER
UNLIMITED™ CONNECTION

1. Make sure the units are OFF.
2. Select the UNIT-TO-UNIT cable (Not included).

3. Insert the cable into the jack labeled “PC LINK” on the back of the PRECOMPUTER
UNLIMITED™ unit.

4, Turn the units on.

PRECOMPUTER UNLIMITED™ PRECOMPUTER UNLIMITED™

B50), "-"‘.‘

- . ol

PC LINK JACK PC LINK JACK

Unit-To-Unit (NOT INCLUDED)

CHAPTER 3 FERTURES

OFF ON

ON/OFF BUTTONS

Turn your PRECOMPUTER UNLIMITED™ unit ON by pressing the green ON button. Turn
the unit OFF by pressing the red OFF button.

AUTO POWER-OFF

If there is no input into the PRECOMPUTER UNLIMITED™ unit for about 15 minutes, the
unit will automatically shut-off to save power. If you want to turn the unit back on after
the automatic power-off has activated, just press the ON button. We recommend that you
turn the unit OFF when not in use.

VOLUME CONTROL

Use the normal volume control on your TV or VCR to adjust the system volume.
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CHAPTER 4 MOUSE AND KEYBOARD

The mouse of this unit functions the same as a real computer mouse. Control the cursor
on the screen by moving the mouse in the direction you would like the cursor to move.
The left button on the mouse functions as an Enter key.

Mouse

Left Mouse Right Mouse This '"ARROW' shows the unlocking
Button direction.Lock by pushing to the
opposite side of the 'ARROW'".

Button

The PRECOMPUTER UNLIMITED™ has a computer-style keyboard with many functions.
Keyboard

ol (] ) T 1
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I |

ESC

Press this key to exit a pop-up window or cancel a selection you have made.

6
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Insert hsm

This key lets you toggle between Insert and Overwrite modes during text editing. Insert
means that any new letters typed will move existing letters to right side and be inserted
between the existing text. Overwrite mode means that any new text typed will replace
existing text.

DELETE

Press this key when you want to delete the character of the cursor position.

Delete

HOME

Press this key to move the cursor to the beginning of a line.

End END

Press this key to move the cursor to the end of a line.

Home

Page Up iﬁ‘,,“‘j
In applications like the Word Processor, Spreadsheet and Database, press this key to move

up one viewing screen. In activities like Equation Maker, Trivia and Word Puzzle, the Page
Up key does not apply.

PAGE
DOWN

Press this key to move down one viewing screen.

Print Screen l Ty

Press this key to send a replica of what you see on the screen to your printer.

Help HELP

Press this key to access the built-in information applying to each application.

Page Down
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Repeat ‘ REPEAT

This key is not used for any main unit application. However it is used in some expansion
cartridges which are sold separately. If applicable, its use will be described in the expansion
cartridge manual.

Answer

ANSWIER ‘

Press this key to see the correct answer to a question. Only use this key in an application
where you are being asked a question, for example, Word Puzzle.

NumLock [~:§ \

Press this key to lock the number pad into numbers only mode. This will deactivate the
arrow keys on the number pad. When the NumLock function is activated, the NumLock
light will turn on.

«=BACKSPACE |

Backspace

Press this key to delete the character just to the left of the cursor position.

i
i

Press these keys to move the cursor. These keys are an alternative for the mouse.

(y o

Arrow Keys l [Q 1

Tab

Press this key to move the insertion point to the next pre-set tab location.

{ CAPSLOCK ‘

CapsLock

Press this key to lock the keyboard in upper case mode. Once this key is pressed all
typed letters will appear in upper case. Press the key again to return to normal typing
mode. When the CapsLock function is activated the CapsLock light will turn on.
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SHIFT ¢

Shift/Player 1 and Shift/Player 2 PLAYER 1

SHIFT +
PLAYER 2

When typing, press this key together with a letter key to type a capital letter or to access
the symbol shown on the top half of a number or symbol key.

When playing a 2-player activity, these are your player keys. Please read the instructions
of each 2-player activity to know how to use the player keys in that activity.

ALT

ALT

The main use of the Alt key is to access keyboard shortcuts for built-in functions. If you
ever see a word in a menu bar with one letter underlined you can press Alt and that letter
to access the options in that menu. For example, ALT+F accesses the File Menu. This
is a time saving way to access options if your mouse is not connected or you are very
advanced on the keyboard.

The main use of the Ctrl key is to perform common tasks more quickly. For example,
you can give the keyboard command to save a file by pressing CTRL+S. For a full list
of Ctrl tasks look in Help under the topic of “Hot Keys”.

Enter ‘ <—ENTER J

Press this key after typing or choosing an answer to confirm your selection.

F1-F10

Tl [
These keys are not used for any main unit application. However they might be used in

a future expansion cartridge. If applicable, their use would be described in the expansion
cartridge manual.

Ll L 0 1)

el

Directional Cursor Pad @ O

Left Fire Button Right Fire Button

Press the Directional Cursor Pad to move the on-screen cursor when you are in a dialogue
box. The Directional Cursor Pad can be used like the mouse. This feature is often found
on portable computers instead of a mouse. Press either of the buttons on the sides of
the Cursor Pad to confirm your selection.
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CHAPTER 5 HOW TO BEGIN

HOW TO BEGIN

When the unit opens you will see the Desktop. You will know it is the Desktop from the
title in the Title Bar at the top, center of the screen. The Desktop is the hub of the unit,
from here you can get anywhere. Each icon you see represents an application or activity
you can enter. You can click on any icon at any time.

- Creativity/ Games sm———————

@ﬂ%l @é

Before you begin here is some general information to make use fun and easy:

1. The Menu Bar is the grey bar just below the Title Bar. It will always begin with File.
Each entry on this bar represents a different menu full of options for the application
you are in.

2. The lcon Bar is the wider, grey bar just below the Menu Bar. When you open a menu
the Icon Bar is where the icons of each option in that menu will be displayed.

3. The Descriptor Box this is also known as the text box. It is the white box toward the
right of the Icon Bar. The Descriptor Box tells you the function of the Icon Bar icon
your cursor is pointing at.

4. The unit has a built-in Demo feature which highlights the uses of some of the more
complex applications. Access to this feature by double clicking on the DEMO icon
located in the lower right hand corner of the Desktop screen.

Notes:

1. Once you select the DEMO icon it will take approximately five seconds for the Demo
to begin.

2. While the Demo is showing, press any key to resume.

3. In the Demo mode, the function of the auto power off will be deactivated. Therefore,
PreComputer Unlimited™ will not turn off automatically.

4. Once the Demo mode has been activated, the auto power off function will remain
deactivated until PreComputer Unlimited™ is switched off. The next time it is switched
on, the auto power off function will resume as normal.

10

Downloaded from www.Manualslib.com manuals search engine


http://www.manualslib.com/

MENU BAR

The most common option in the Menu Bar is File. Here are directions to use the functions
which will appear under the File Menu. Since different applications have different purposes
not every File option will appear in every application. However this is a complete list for
your reference:

Begins a new, blank file in the current application.

1. Open the File Menu.

2. Click the NEW icon.

3. A blank file of your current application should appear.

OPEN

Opens a file currently existing in memory.
1. Open the File Menu.
2. Click the OPEN icon.

3. From the pop-up window select “Main Unit” or “Cartridge” to tell the unit where your
file is stored. (Cartridge only applies if you have purchased the RAM expansion cartridge
separately and it is currently inserted.)

4, Click “Yes".

5. In the next pop-up window highlight the folder containing the file you want. (If you have
created no folders “USER” will be your only option.)

6. Click “Yes”.
7. Scroll through the list of files and highlight the name of the file you seek.
8. Click “Yes" to open the file.

Note:  You must be in the file’'s application for the file to open. For example, you could
not open a Typing Tutor file from the Word Processing application.

SAVE

Allows you to put a file into the computer's memory or to overwrite an existing file of the
same name. If you are saving a file for the first time, the unit will automatically default
to the SAVE AS option. Please see below for a description of the SAVE AS procedure.
If you are resaving a file you have opened and edited, selecting the SAVE option will overwrite
the old file. This is fine if you are confident in your changes. If you would like to think
about them some more, do as SAVE AS so that both files remain in your computer’s memory.

11
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SAVE AS

Allows you to put a file into the computer’s memory or to store an edited file under a
new name.

1. Create a file.

2. Open the File Menu.

3. Select the SAVE AS icon.

4. Select either Main Unit or Cartridge. (Cartridge only applies if you have purchased the
RAM expansion cartridge separately and it is currently inserted.)

5. Click “Yes".

6. Select a folder. (If you have not created any folders your only option is “USER”.)

7. Click “Yes”.

8. Since your file has never been saved before, the unit will ask you to name it. Type

in the name of the file in the space provided in the pop-up window. You can select
any combination of letters and numbers, but no name can take up more than 8 spaces.

9. Click “Yes”.

Saving is complete when the hourglass disappears.

PRINT

Allows you to get a hard copy of your file by sending it to the printer. Be sure to go
to the Printer Setup in the Control Panel before attempting to print a file from your unit.

1. Open the File Menu.
2. Select the PRINT icon.

3. Select “All” if you would like your entire document to print. Select “Page” and fill-in
the appropriate number (i.e.: 5) if you would only like certain page of your document
to print.

4. Type the number of copies you would like in the “Copies” section.
5. Click “Yes”.

DRIVE

Changes which memory location the unit accesses - Main Unit or a Cartridge. f you do
not have the RAM expansion cartridge (sold separately) inserted the unit will only let you
select Main Unit.

1. Open the File Menu.
2. Select the DRIVE icon.
3. Select either Main Unit or Cartridge.
4. Click “Yes”.
12
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EXIT

Lets you leave an application.
1. Open the File Menu.
2. Select the EXIT icon.

CHAPTER 6 ADVANCED CALCULATOR

A calculator is one of the most useful accessories that a computer can provide. This unit

offers you 2 types of calculators to choose from. To select the calculator capable of more
advanced, scientific functions, double click the Advanced Calculator icon |; 5l on the

Desktop.

ADVANCED CALCULATOR

This calculator inciudes a set of scientific functions and the ability to include 18 levels of
parentheses. To see how the parentheses work, type in this equation:

6 * {[ {[7+4]}-21}=54

The calculator will first add 7+4 for 11, then subtract 2 for 9, finally it will multiply 6*9 for
54. Parentheses tell the calculator in what order you would like the equation performed.

The Advanced Calculator also supports the constant feature “K*. When you press an
operation button, like + or *, twice after a number is entered, a K appears on the display.
When you see the K you know that the next number you enter will be used as a constant
for calculations. For example, if you want to calculate 80% of every purchase to give your
customers a discount you type in the following:

“100%*, 80 =" and the result is 80
then type
“200 =" and the result is 160
The Advanced Calculator allows for a series of keyboard commands to quickly call up various

functions. The following table summarizes these commands. A list of shortcut keys is also
available in the Help section of the calculator program.

13
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Icon Shortcut Keys Function

Clears any value stored in memory

Recalls the value stored in memory

Stores the displayed value in memory

=] Adds the displayed value to any value in memory

i Starts a new level of parentheses

Closes the current level of parentheses
Inserts a decimal point in the displayed number
Calculates the common logarithm
Calculates the anti-logarithm

Allows entry of scientific notation

Computes X to the Yth power

Calculates the Xth root

Displays the value of Pi

Enters the displayed number in the data box
Calculates the sum of the data

Calculates the sum of the square of the data
Calculates the population standard deviation
Calculates the arithmetic mean

Opens the statistics mode

Opens the binary mode

Opens the octal mode

Opens the decimal mode

Opens the hex mode

Tip: When using the statistical functions be sure to press SD first.

14
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CHAPTER 7 ART STUDIO AND CLIP ART
DRAWING

To enter the Art Studio or Clip At Drawing application, double click the Art Studio icon

Experimenting with the features of the applications is the best way to learn how to use
the Art Studio or Clip Art Drawing. Begin with the tools then try the various options under
the menus. You can save and print your favorite pictures.

The Clip Art Drawing works just like the Art Studio but serves the special purpose of allowing
you to design your own clip art for use in the Report Writer and Word Processing programs.
Save these special creations in a folder. If you have a large number of these, they are
best transferred to a PC using Power Link™ as they take up too much memory.

TOOLS

The tools are located on the left hand side of the screen. First there is a set of eight
tools grouped together, this is the toolbox. Below the toolbox is the palette icon; this looks
like a box within a box. Below the palette icon is the line icon; this looks like a box with
a horizontal line through it.

Toolbox

To select a tool from the toolbox click any toolbox icon. Follow these directions for using
each tool:

wd Straight Line - Select the Straight Line icon. Move the cursor to the spot on the drawing
screen where you would like your line to begin and click once. Next move the cursor to

the place where you want the line to end and click again. Do not hold down the mouse
button while moving to the end of the line.

15
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9| Freehand Line - Select the Freehand Line icon. Move the cursor to the drawing screen.
Press and hold the left mouse button and begin to draw. Continue to hoid down the mouse
button while you are drawing. Release the mouse button when done.

4] Spray Paint - Select the Spray Paint icon. Move the cursor to the drawing screen.
Press and hold the left mouse button and begin to spray. Continue to hold down the mouse
button while you are spraying. Release the mouse button when done.

ig| Paint Filler - Select the Paint Filler icon. Move the cursor to the area of your drawing

tat you would like to fill with color. The Paint Filler tool will fill in a shape on the drawing
screen with the current color in the palette. Click the left mouse button to start the filling.
Look out for any holes in the shape you are coloring, the paint will “leak out” of any gaps.

{, Text - Select the Text icon. Move the cursor to the point where you would like the
text to begin and click once. An insert line will appear. Use the keyboard to type in your
text. When you finish typing, click the mouse to lock the text on the screen. Once you
lock the text, it becomes just like any other graphic on the screen, so you must use the
eraser, not the backspace, to delete it.

-

™ Eraser - Select the Eraser icon. Move the cursor to the drawing screen. Press and
hold the left mouse button while moving the cursor back and forth over the area to be
erased. Continue to hold down the mouse button while you are erasing. Release the
mouse button when done.

L Rectangle - Select the Rectangle icon. Move the cursor to the spot on the drawing
screen where you would like the rectangle to begin and click the left mouse button once.
Now move the cursor away from the origin point. As you move away you will see a rectangle
develop. Move the cursor around the screen until the rectangle is the size you desire,
then click the left mouse button once. This will freeze your rectangle in place.

4| Ellipse - Choose the Ellipse icon. Move the cursor to the spot on the drawing screen
where you would like the ellipse to begin and click the left mouse button once. Now move
the cursor away from the origin point. Do not hold the mouse button down. As you move
away you will see an ellipse develop. Move the cursor around the screen until the ellipse
is the size you desire, then click the left mouse button once. This will freeze your ellipse
in place.

16
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Palette

1| Double click the Palette icon and the color palette will appear. Select your color

by clicking on it then clicking on “Yes” to confirm your decision. Click “Cancel” to leave
the Palette without making a color change.

Line Width

—1] Double click the Line Width icon and a pop-up window will appear. Select either
the thin or thick line by clicking the diamond in front of the option. Next click on “Yes”
to confirm your decision. Click “Cancel” to leave the pop-up window without making a line
width change.

MENU BAR

|

File Menu

The File Menu helps you manage your creations. In the File Menu you can open new
or existing files, save or save as, print, change drives or exit the application. Please see
the Chapter 5 (HOW TO BEGIN) section of the manual for detailed instructions on using
these options.

Edit Menu

B
The Edit Menu allows you to cut, copy, or paste items in the drawing area. All of these
tools work the same way, the cut tool will be used as an example. Select the Cut icon.
Move the cursor to the spot on the drawing screen where you would like the cut to begin
and click the left mouse button once. Do not hold the mouse button down. Now move
the cursor away from the origin point. As you move away you will see a rectangle develop.
Make sure this rectangle encompasses the entire object you would like to cut, then click
the left mouse button once. This will move everything inside the rectangle to the clipboard.

In Cut the object will disappear; in Copy the object will still be visible on the screen and
a copy will be on the clipboard.

To paste an item from the clipboard, select Paste from the Edit Menu. Move the cursor
to the location on the drawing screen you would like the clipboard item dropped. You will
see the outline of your rectangle reappear as the cursor moves. When the rectangle is
where you would like the clipboard item click the left mouse button once. The clipboard
item will drop inside the rectangle. You can repeat the Paste procedure as many times
as you like, the clipboard will not become empty until you exit the application or replace
it with a different object.

17
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Insert Menu

The Insert Menu contains six pages of clip art graphics which you can add to your picture.
Each icon under the Insert Menu represents a different page of graphics. The pages are
categorized as follows: Transportation, Events, Animals, Things, Food, and Landmarks.

After you have chosen one of the pages, a list of graphic will appear in a box on the
screen. You can scroll through the choices in the box by clicking on the arrows on the
right side of the box. To select a graphic highlight its title then click on “Yes”. You will
shift back to the drawing screen and see a rectangle attached to the cursor. Move the
rectangle to the location you would like to place the graphic and click on the left mouse
button. The unit will now freeze your selection in this location. Remember the pictures
are large so give yourself plenty of room.

Ei

Effects Menu

The Effects Menu options work like the Edit Menu options. The Move tool will be used
as an example. Select the Move icon. Move the cursor to the drawing screen and click
the left mouse button once on a corner of the area to be changed. Now move the cursor
away from the origin point. As you move away you will see a rectangle develop. Make
sure this rectangle encompasses the entire object you would tike to change, then click the
left mouse button once.

If you are using the Move tool you will see the rectangle you created remain stationary
while a new rectangle becomes visible, attached to the cursor. Move the new rectangle
to the location you would like to move the object and click the left mouse button once.
The unit will lift the contents of the original rectangle and drop it inside the second rectangle.
If you are using the Rotate or Mirror tool, no second rectangle will appear. Rather the
unit will immediately perform the requested action.

Fonts Menu u’ Fﬂ

The Fonts Menu is easy to understand. Before typing with the Text tool, choose the font
you would like to use from this menu. There are six options available consisting of 3 different
sizes of text and a normal and bold option for each size.

([

The View Menu allows you to vary the viewing perspective of your drawing. One of the
most frequently used options on the View Menu is the Zoom In option. This option aliows
you to view a section of your drawing close-up. Choose the Zoom In option from the menu.
Move the cursor to the drawing screen and click the left mouse button once on a cormner

View Menu

18
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of the area to be viewed. Now move the cursor away from the origin point. As you move
away you will see a rectangle develop. Make sure the rectangle does not get too large,
you can only Zoom In on a specific area. When your area is inside the rectangle, click
the left mouse button once. In the Zoom In mode you can make detailed adjustments
to your drawing.

Selecting Zoom Out on the View Menu will retum you to the normal viewing level.

The third option of this menu is another way of accessing the color palette. Click on the
Palette icon to have the color palette appear.

;H‘
i

Help Menu ,“:\

Choosing the Help Menu in Art Studio or Clip Art Drawing applications will produce a list
of topics pertaining to the Art Studio or Clip Art Drawing functions.

TIP

The Art Studio pictures require a great deal of the computer’s memory. Using the print
options allow you to retain a copy of your work without running out of memory.

CHAPTER 8 BASIC

For years BASIC has been one of the first programming languages people learn. Initially
it was designed to help students write computer programs and is now a standard software
component of most microcomputers.

The BASIC application of the PRECOMPUTER UNLIMITED™ lets you write and run BASIC
programs. You learn BASIC by typing in simple programs and then changing them to see
what happens. By trial and error you can enter the world of programming and experience
success. Start slow and build up your skills.

HOW TO BEGIN

When you enter the activity you will see 4 available menus (File, Run, List, and Help) and
a white screen with the prompt “Main>" appearing in the upper. left hand corner. This
prompt indicates that the computer is ready to receive your program. Like all computers,
you must type a program into the PRECOMPUTER UNLIMITED™ unit in order to run it.
A BASIC program is made up of a series of numbered lines, each line containing a command.
A command tells the program to do something. Place a number in front of a command
in order for the computer to know you are entering a line of a BASIC program.

19
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Menus

File Menu

e |

The File Menu helps you manage your programs. In the File Menu you can open new
or existing files, save or save as, print, change drives or exit the application. Please see
the Introduction section of the manual for detailed instructions on using these options.

Run Menu

ol

There is one icon under the Run Menu. Once you have finished writing a program, click
this icon to make the program execute.

w | ]

List Menu

There are 2 icons available under the List Menu - ALL and RANGE. By using this
command you tell the computer to list a designated set of lines of code. The computer
will list all lines of code if you choose ALL, or it will list lines within a range you designate
if you choose RANGE. If you have a short program then list ALL works well, but after
awhile your programs will be too long for this to be effective. For long programs, use the
RANGE function. When the pop-up box appears, type in the line numbers you would like

20
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to view in this format “20-60". Then Click “Yes”. All the lines you selected should appear
followed by a prompt for your next instruction.

‘H}

Help Menu {“7\

Choosing the Help Menu will produce alist of topics pertaining to the BASIC application.

Actual Programming

To make the use of line numbers and commands more clear, let's enter a simple example.
Type the words to the right of the prompt exactly as shown below. Press ENTER at the
end of each line.

Main> 10 print “Hello Friends”

Main> 20 print “Hi”

Traditionally the numbers chosen for BASIC programs are multiples of 10. This is important
because later you can easily insert other command lines by using numbers between the
original line numbers. You will find yourself doing this again and again. Either you forget
a crucial command or you want to make an addition to enhance the program after you
see it running. To erase a line type the number and press ENTER.

If you make a mistake on a line and have not pressed ENTER then use the BACKSPACE
key. If you have pressed ENTER then you must retype the line beginning with the line
number.

After entering the command lines above select the RUN icon under the Run Menu, press
ALT+R, or type “run” at the “Main>" prompt then press ENTER. When the computer follows
your commands in sequential order, it will print “Hello Friends” then “Hi” on the screen.
You can run the program as many times as you want by choosing the RUN command
again.

When programming you should always save your work often and early. This way, if anything
should go really wrong, you can always regroup by opening the saved file and only losing
the changes you made since the last SAVE. As mentioned before, the SAVE icon is under
the File Menu.

Program Status Bar

The bottom line of the scree . keeps you informed of some
foundational information about your program. The file name appears on the far left of the
line (Note: No name will appear until you have saved the program). On the right hand
side of the bar are the keyboard indicators - INS, CAPS, and NUM. INS tells you whether
or not you are in Insert mode. CAPS corresponds to the Caps Lock option. And NUM
represents the Numbers Lock option. When these options are off the indicators will be
grey. If you activate any of these options the indicator for that option will turn black.
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BASIC Concepts

Array of Variables - This is a list of variables that operates similarly to a table or spreadsheet.
You create the array, then fill it with data.

String Variable - A single variable of a designated length. The length is usually longer
then the normally allotted amount (50 Bytes). However, you can use a string variable to
make variables smaller to conserve memory.

Subroutine - This is a small program within a larger program which is called upon to perform
a specific task. For example, if you worked in a store you may develop a subroutine which
calculates sales tax. You could then call on this subroutine every time a purchase was
made.

Variables - This is the computer name for the data spaces you allot in memory. For example,
if you say LET A=4. You create a variable named “A” and it has a content called “4”".
Variables can change as the program runs.

BASIC Statements

These are the commands that form the operational heart of BASIC programming. You will
see these commands in the BASIC Tutor application.

BEEP FOR...TO..NEXT...STEP LPRINT RESTORE
CLEAR GOSUB PRINT RETURN
DATA GOTO PRINT USING  STOP
DIM IF... THEN...ELSE RANDOMIZE
DO..LOOP INPUT READ
END LET REM

BEEP

The BEEP statement causes the built-in sound system to send a beep to the speaker.
This is helpful when programming games or to let the user know that something important
is happening.

CLEAR

CLEAR reserves space in the computer for string variables. If you do not use CLEAR then
50 bytes of space are reserved for a string variable. CLEAR 200 would clear 200 bytes
of space. Using CLEAR reduces the amount of space useable by the program.

DATA

DATA is used to store data in the program for use as the program is being executed. It
is most often used when the information does not change frequently. The DATA statement
is read by the READ statement.

10 DATA “Sally”, “George”
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20 READ Girl$, Boy$
30 PRINT Girl$, B0y$

After running this program, the string variable Girl$ would contain “Sally” and the variable
Boy$ would contain “George”. It is very important that the READ and the DATA statements
match. This means that the data to be read actually fits into the variable in the READ
statement. The PRINT statement shows that the READ command really works.

DO...LOOP

Computers repeat commands often and well. This is part of their real appeal. DO... LOOP
means complete the statements between DO and LOOP until the looping condition becomes
false. For instance:

10 DO

20 PRINT “This is a great school”
30 Count =Count + 1

40 LOOP While Count < 10

50 END

If the count starts out at 0 then this program will print the saying 10 times and then quit
with the END command in line 50.

DIM

The DIM variable at the beginning of a program reserves space for an array of variables.
If the DIM statement is not used at the beginning of a program then arrays that are declared
will have 11 items. Each array can only hold the same type of information.

10 DIM Name$(19) wouid reserve space for 20 names on a list.

20 DIM Trans$(49,4) would reserve space for 50 items with 5 pieces of information about
each item. Each piece of information is a string.

END

END terminates any program and returns you to the operating system. This is different
from the STOP command which would allow you to continue your program. If you use
END, you will have to type RUN to begin the program again.

FOR...TO...NEXT...STEP

This powerful command initiates a loop of instructions to be performed a set number of
times. Some form of counter usually increases from an initial to a final value in a series
of steps. Each time through the loop the instructions are performed. If you do not indicate
a value for the step then it is assumed to be 1.
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Type in this example:

10 FOR Cent=1TO 30 STEP .5

20 Fahr=9/5* Cent + 32

30 PRINT Cent; “ Centigrade = ”;Fahr; “ Fahrenheit”
40 NEXT Cent

Choose the RUN command from the menu bar and watch what happens. All the temperature
conversions between 1 and 30 degrees centigrade are calculated in .5 degree intervals
to Fahrenheit.

GOSuUB

GOSUB tells the program to go to a subroutine of commands elsewhere in the program,
perform the commands found there, and return to the next sequential command in the main
program when done. The subroutine retumns to the main program when the RETURN
statement is encountered.

Type in the following example:

10 PRINT “My Friends”

20 GOSUB 100

30 PRINT “Those were my friends.”

40 END

100 REM *** Friends List Subroutine **3*
120 PRINT * George”

130 PRINT * Sally”

140 PRINT “ Tom”

150 RETURN

Subroutines are important in BASIC and other programming languages. By creating good
subroutines you can use them again and again in the same program or other programs.

GOTO

This command jumps to another line number without any automatic way to return.
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Understanding a program with many GOTO commands can be very difficult. Experienced
programmers try to use this command as little as possible or not at all.

Try this example:

10 GOTO40

20 PRINT “Good-bye”
30 END

40 PRINT “Hello”

50 GOTO20

IF...THEN...ELSE

IF statements branch to another part of a program when a certain condition is true. If
the condition is not true then the program continues on to the next sequential line. Imagine
yourself on a freeway. If this is your exit then you turn off, if not then you continue on
as before.

See how this works in the following example:

10 INPUT “Your Age Please ’; AGE

20 IF AGE > 20 THEN 50

30 PRINT “ You are in the computer generation.”

40 GOTO 60

50 PRINT “Congratulations on learning about computers!”

60 END

In this example the condition was AGE > 20. If that was true then the program branched
to line 50 otherwise the program continued on to line 30.

INPUT

The INPUT command is one of the most powerful and useful BASIC commands. lts job
is to receive information from the keyboard. The INPUT command can contain a phrase
that asks the user for a desired response. The variable where the information is stored
is the final part of the INPUT command.
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Type in this example:

10 INPUT “Your Name Please >’:Name$
20 PRINT Name$

In this example “Your Name Please” is a phrase that asks for input and Name$ is the
variable where that input is stored.

LET

LET is the formal statement that can be used to assign values to numeric and string variables.
Actually LET is optional, but it makes the meaning of the assignment statement clear.

10 LET N§$ = “Peter”
20 LET X=X+1

Line 10 assigns the value of “Peter” to the string variable N$. Line 20 does the somewhat
unusual process of taking the value in the X variable, adding 1 and placing the new total
back in the X variable. In English we would say “Let the value of X be assigned the current
value of X plus 1.”

LPRINT

LPRINT has the same syntax as the PRINT command only the output would go to the
printer instead of to the screen. Be sure the printer is properly connected to the computer
and turned on before using the LPRINT command in a program. See PRINT for a more
complete description of the PRINT options.

PRINT

PRINT is the primary output statement in BASIC. PRINT and PRINT USING offer a wide
variety of formatted output possibilities. PRINT statements can combine variables and
comments is the same line.

For exampie:

10 PRINT “Hello”;Name$
20 LET X=10

30 LET Y=2

40 PRINT X*Y, X/Y,X*Y
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The semicolon in a PRINT statement places the two parts of the statement (comment and
variable) next to each other. The comma in a PRINT statement moves to the next column
on the screen. This is helpful for making tables.

PRINT USING

This statement helps format the output of information. This is important for reports and tables.
The command requires a string of characters to describe the format and then a number
or string to be formatted.

To print out the first character of a string of characters use this statement:

10 LETAS$ = “Horse”
20 PRINT USING “I””; AS

The ! format means the first character of the string.
Other ways to use PRINT USING include:

10 PRINT USING “##.##7;,.78 (would print 0.78 on the screen)

## signs are replacement for digits in a formatted output.

10 PRINT USING “+##.##”;-68.95 (would print -68.95 on the screen)

RANDOMIZE

RANDOMIZE tells the computer to generate a new random number “seed number” or starting
point. Computers will always generate the same random number sequence unless told to
pick a new “seed number” to start the sequence.

READ

The READ statement tells the program to read the data in DATA statements into variables.
Each READ continues through the DATA sequentially. The RESTORE command tells the
computer to return to the first item in the DATA statements and begin reading again. You
will frequently see READ and RESTORE used together.

REM

The command tells the computer that what follows is not part of the program, rather it
is @ comment or remark from the original programmer to another programmer who may
be reviewing the code lines. Comments or REMarks in programs do not affect the execution
of the program but are very useful for others to understand how a program works. They
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provide the documentation for a program. Good programmers use REMarks often.

RESTORE

As stated before, the RESTORE command is used to cause the READ command to start
at the beginning of the DATA statements again.

RETURN

This command is found at the end of a subroutine. It returns the flow of the program
to the next sequential command after the GOSUB command that called the subroutine.

STOP

STOP halts the execution of the program. This is useful for debugging purposes. You can
pause a program to see what is happening and check for errors.

BASIC Functions

Functions are operations on strings and numeric values that are of special use in particular
situations. The following is a list of functions available in this unit. Remember, all functions
must be tested in a base command line. For example,

10 PRINT ABS(-6).

Name Purpose Example
ABS(X) Returns the absolute value ABS(-6) = 6
ASC(A3) Returns an ASCIi Code ASC(“A”) = 65
ATN(X) Returns the arc tangent in radians ATN(60) = 1.55413
CHRS$(N) Returns the character represented N CHR$(65) = A
by the ASCIl code
COS(X) Returns the cosine function COS(60) = -.952413
EXP(X) Returns the exponential EXP(2) = 7.38906
e to the power X
INX (X) Returns the integer portion of INT(5.96) = 5
any number
LEFT$(AS,N) Returns the left N characters LEFT$("DOG",2)=DO
of the string A$
LEN (A$) Returns the length LEN(“Dog”) = 3
of the string
LOG(X) Returns the natural log X> 0 LOG(10) = 2.30259
MID$(A$,M,N) Returns the middle N MID$(“HORSE",2,2)=0OR

characters beginning at
character M

RND(X) RND(0) returns a number RND(0)= 0.36754
between 0-1. INT (1+RND(0)*X)
returns an integer between 1 and x.
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SGN(X) Returns the sign of X SGN(-4) = -1

SGN(7) = 1
SGN(@©) = 0
Sin(X) Returns the sine of X SIN(60) = -.304809
SQR(X) Returns the square root of X SQR(9) = 3
STRS(N) Returns the string value of the STR$(10) = 10
number N
TAN(X) Returns the tangent of X TAN(60) = .320039
VAL(AS) Returns the numeric value of a VAL("10")=10

string of characters

BASIC Error Messages

Sometimes when programming you will make a typo or give the computer a command it
does not understand. When this occurs the computer will tell you know that it cannot go
on and gives you an Error Message which will help indicate the problem. Sometimes error
messages can be hard to figure out since the mistake can be as small as a missing comma.
But with practice you will get better at troubleshooting for errors.

error you must retype the entire line beginning with the number.

ERROR MESSAGE THAT
APPEARS ON THE SCREEN

DIVISION BY ZERO

ILLEGAL FUNCTION
CALL

FOR WITHOUT NEXT

OUT OF DATA ERROR

program.
OUT OF STRING SPACE

OVERFLOW
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ERROR

?DIVISION BY ZERO ERROR
Somewhere you are trying to divide by zero.

?FUNCTION CODE ERROR

A parameter that is out of range is passed to a math
or a string function. This error may occur as a resuft of:
1. a negative or unreasonably large subscript.

2. a negative or zero argument with LOG.

3. a negative argument in SQR.

4. a negative mantissa with a non-integer exponent.
5. an improper argument to MID$, LEFTS.

?NEXT WITHOUT FOR ERROR

The variable mentioned in the NEXT command
does not have a corresponding FOR command
variable.

?0UT OF DATA ERROR
A READ statement is executed when there are no
DATA statements with unread data remaining in the

?0UT OF SPACE ERROR
String variables have caused BASIC to exceed the
amount of free memory remaining.

?70VERFLOW ERROR
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REDIMENSIONED ARRAY

REDO

RETURN WITHOUT

GOsuUB

STRING TOO LONG

SUBSCRIPT OUT OF
RANGE ERROR

SYNTAX ERROR

TYPE MISMATCH ERROR

UNDEFINED STATEMENT

MISSING OPERAND

The result of a calculation is too large to be
represented in BASIC. The largest number allowed is
10 to the 38th power.

?REDIM'D ARRAY ERROR

Two DIM statements are given for the same array,
or a DIM statement is given for an array after the
default dimension of 10 has been established for that
array.

?REDO
A string is assigned to a numeric variable during
the execution of the input command.

?RETURN WITHOUT GOSUB
A RETURN statement is encountered without a
previously executed GOSUB statement.

?STRING TOO LONG ERROR
An attempt is made to create a string of more than
255 characters.

?7BAD SUBSCRIPT ERROR
An array element is referenced either with a subscript
that is outside the dimensions of the array, or with the
wrong number of subscripts.

?7SYNTAX ERROR

A syntax error can be a spelling error, punctuation
error, or mismatched parentheses.

This is the most common error seen by beginning
programmers.

?TYPE MISMATCH ERROR

A string variable name is assigned a numeric value
or vice versa. A function that expects a numeric
argument is given a string expression or vice versa.

?UNDEF'D TATEMENT ERROR

A line number referenced in a GOTO, GOSUB, or
IF.. THEN statement

is non-existent.

?MISSING OPERAND ERROR
An operand is missing following an operator in an
expression.

CHAPTER 9 BASIC CALCULATOR

The Basic Calculator looks like a traditional, hand-held calculator with the added feature
of an electronic paper tape. As with a normal calculator you click on the numbers to enter

them on the dispiay.
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To enter the Basic Calculator application double click the Basic Calculator icon - on
the Desktop. The screen will change to show a calculator and a menu bar with 2 options.

MENUS

File Menu @@

Because of the nature of the calculator applications, only the EXIT icon is available under
the File Menu.

Help Menu {‘" J f':i

Choosing the Help Menu in the Basic Calculator will produce a list of topics pertaining
to the Basic Calculator functions.

BASIC CALCULATOR

This calculator allows 10 significant digits to be displayed on the calculator screen along
with 2 digits for an exponent. If a number exceeds these limitations an “E” will appear
on the screen. If you see the “E” you must either use smaller numbers or switch to the
Advanced Calculator.

The added feature of this calculator is the simulated paper tape to the right of the caiculator.
This is where you can keep track of your calculations and even edit them. When you click
on the operator keys the numbers and operators in your equation appear on the simulated
paper. It consists of a series of horizontal lines, where the numbers and operations you
type in will go, as well as a red triangle with scroll bar on the far side of the screen.
The red triangle points to the line which your next entry will be put on.

The scroll bar lets you view operations which have scrolled off the screen but are still a
part of the current calculations. The scroll bar and red triangle are aiso used when editing
an equation.

To use the Edit command click on “Edit” in the lower right hand corner of the screen (or

press -|@ ). Use the scroll bar on the far right of the screen to make the red triangle
point at the number you would like to modify. When the red triangle points at a number

31

Downloaded from www.Manualslib.com manuals search engine


http://www.manualslib.com/

in Edit mode the number will be highlighted. This means the number will be replaced
by whatever number you type next. After you type in the new number press ENTER or
the “=" key to recalculate the entire equation. Click on the Edit key to exit the edit mode.

KEYBOARD COMMANDS

The Basic Calculator has the following keyboard commands to quickly call up various
functions. A list of shortcut keys is also available in the Help section of the calculator
program.

lcon Shortcut Keys Function

Clears the vaiue stored in memory

Recalls the value stored in memory

gt N Stores the displayed value in memory

] Adds the displayed value to the value in memory

TIPS

1. You can save numbers in the memory and recall them when needed.

2. While you are entering a number you can edit the number by pressing the backspace
key. Once the number is entered then you must use the Edit command to change it.

3. If you are doing a multi-step equation do not hit “=" between segments. Instead just
press the next operation to continue. (Pressing “=" will end the equation.)

CHAPTER 10 BASIC TUTOR

BASIC is a computer language that was especially designed for student use. The commands
are relatively simple yet allow you to control how a computer functions and achieve some
interesting results. The BASIC in the PRECOMPUTER UNLIMITED™ can serve as an
introduction to the programming principles found in more advanced programming languages
like C++ or Pascal.

The BASIC Tutor will acquaint you with the fundamental BASIC commands using a series
of simple practice programs. These programs are already entered into the computer. Follow
the commands below on each program to see which principles are being demonstrated.
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An interesting way to practice with BASIC is to type these sample programs into the BASIC
application of the PRECOMPUTER UNLIMITED™, check to see that the programs work,
then make changes to see if you can get the programs to do similar yet different activities.
Copying and modifying examples is a great way to become familiar with computer
programming.

An important tocl of the BASIC Tutor is the Key Words list. BASIC has a series of Key
Words that mean special things to the computer. This list represents the vocabulary of
BASIC. The Key Words list of the BASIC Tutor explains each Key Word and how it can
be used. You will find yourself referring to this list often while learning to use BASIC
commands properly. This is important because computers cannot understand what you
intend to say but only exactly what you say. Key Words will help you get the meaning
correct and catch “bugs” or mistakes in your programs.

HOW TO BEGIN
To enter the BASIC Tutor application, double click the BASIC Tutor icon ‘t«?’ on the Desktop.

You will see a large white screen and a menu Bar with 4 options: File, View, Print, and
Help.

MENU BAR

ALT ‘F_l

File Menu

The EXIT icon is located under the File menu.

=

There are 2 options under the View Menu - Key Words and Sample Codes.

View Menu

Key Words

When you click on the KEY WORDS icon under the View Menu a pop-up screen will appear.
Scroll through the options to see all the Key Words available. Any word in the list is a
command word for BASIC. To see a definition outlining the use of the command, highlight
the Key Word then click “Yes”. A definition will appear on-screen.

Sample Codes

Sample Codes is another name for Sample Programs. When you click on the SAMPLE
CODES icon under the View Menu a pop-up screen will appear. Highlight the name of
the Sample Code you would like to see then click “Yes”. The code lines will then appear
on the screen. See Sample Codes below for a detailed description of each program.

33

Downloaded from www.Manualslib.com manuals search engine


http://www.manualslib.com/

Print Menu

iAn ’ }}; !
: i
| L

When your printer is hooked up to the unit, by clicking on the PRINT icon you will receive
a hardcopy of whatever file is open on the screen.

H‘
J

Help Menu o

Choosing the Help Menu will produce a list of topics pertaining to the BASIC Tutor application.

Sample Codes
Here is a list of the Sample Codes and what each teaches:
PIGS teaches foundational BASIC commands.
PETNAME teaches about input and output.
GUESS covers IF...THEN statements, making decisions and branching.

CODES gives more information on IF...THEN statements, making decisions and
branching.

PHONE introduces the READ - DATA commands linked with reading data from a program.
AGENAME introduces the functions of LEFT$ and MIDS$.

PALS covers FOR...NEXT statements.

ANIMALS goes more in-depth on FOR...NEXT statements.

CHANCE introduces GOTO for a look at subroutines.

Here is an in-depth explanation of each Sample Code. Notice that each of the lines is
numbered. This is required in the original version of BASIC and helps you clearly see
the sequence of the program. Explanations appear after each line of code.

Example 1 - PIGS

10 PRINT “THREE LITTLE PIGS”

Print is a BASIC command that takes the data in quotes and puts it on the screen.

20  PRINT “HOW MUCH DID THEY WEIGH?”

Another title line to print on the screen.

30 LET P1=345
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Creates a variable P1 and places the value 345 in that variable. Think of variables as
mailboxes in a large apartment building. Like mailboxes, variables hold information which
can be read and/or replaced. When creating a variable, it is important that the variable
name is always on the left of the equation. 345=P1 does not have the same meaning
as P1=345.

40 LET P2=456

Creates the second variable and puts 456 into it.  Assume the numbers are pounds.

50 LET P3=567

In all three statements “LET” means “Let the variabie (P1, P2, or P3) be filled with the
value on the right of the equation.

60 LET SUM =PI +P2+P3

Creates a new variable called “SUM” and inserts the value of P1, P2, and P3 added together
into SUM. This command will not print the sum on the screen, just store it in a memory
location called SUM.

70 PRINT SUM

This command will print the value of SUM on the screen.

80 END

END is the BASIC command that halts the execution of the program.

When BASIC was invented, many programs were written to solve math and engineering
problems. Manipulating numbers is a powerful reason for developing programs.

Example 2 - PETNAME

PETNAME shows that computers can handie strings of characters as well as numbers.
It also looks at some of the more powerful tools of the Print command.

10 LET PET$="BTUTOR”
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The $ sign after PET indicates this variable is to hold a string of characters or a word.
Although a string variable may be a number to us, you cannot add or subtract with the
value of PET$. A string variable is not a number to the computer.

20 PRINT “I AM THE ";PET$

This Print statement combines a string constant, “I AM THE” with a string variable PET$.
The semicolon between them tells the program put them right next to each other on the
same line.

30 INPUT “WHAT IS YOUR NAME ”;NAMES$

Input is a powerful statement that does two things. First the prompt “WHAT IS YOUR NAME”
is printed on the screen with a question mark. Then the computer waits for the user to
type a response and stores the response in the string variable called NAMES.

40 PRINT “HELLO ”;NAME$

This print command continues the dialogue between the user and the computer.

50 INPUT “HOW OLD ARE YOU ”;AGE$

Another Input command. Notice that AGE$ is a string variable. Even though the user types
in a number, the computer treats the response as a string of characters. You can't add
or subtract the value stored in AGES$.

60 PRINT “SO ";NAMES$;“ IS ”;AGES;“ YEARS OLD ”

This more complicated line repeats the information entered and makes a new sentence
combining string constants and string variables.

70 PRINT “ I HOPE WE HAVE FUN!!”

A final message printed on the screen.

80 END
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Each program should have an END to halt the program.

BASIC became popular partly because of the power and simplicity of the INPUT and PRINT
commands. Establishing a dialogue with the user was easy to do and the results could
be formatted on the screen in a variety of ways.

Example 3 - GUESS

Programming languages all support branching. This means that depending on whether a
condition is true or false affects which line the program will jump to next. Programs run
sequentially unless instructed to branch to another location. The GUESS program illustrates
this by having the computer pick a number between 1 and 100 and then asking the user
to try to guess the number.

10 H=100

This puts the number 100 into the variable H. For our program H stands for High. So
the highest possible number is 100. Notice the LET command is missing. LET is optional
in most versions of BASIC.

20 L=1

This sets the minimum number in the variable L at 1. L stands for Low in this case. I
you are working with this program, you could change the high and low limits to anything
you wanted.

30 PRINT “PICK FROM 1-100”

This message tells the user about the program.

40 N=INT(RND(1)*(H+1-L)+0.5) +1

This is our first encounter with a Key Function of BASIC. RND(1) chooses a random number
between 0 and 1. INT takes the integer of a number. It would be impossible to guess a
real number with so many decimal points. The formula selects a random number between
1 and 100 and puts it in the variable N. For now just keep this in mind and copy it whenever
you need a random number.

50 INPUT “ TYPE YOUR GUESS ”;G
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The familiar input command prints the prompt on the screen, waits for the user to enter
a guess, and waits for the user to press ENTER. If the user types a character the computer
will respond with an error message and crash. Numbers can be strings but strings can't
be numbers.

60 IF G=N THEN GOTO 120

IF G=N compares the guess and the computer number. IF the two numbers maich, the
condition is considered true; the program jumps to line 120 and continues from there.

130 END

With more modern versions of BASIC the GOTO statement is seldom used. But the real
focus of this example is to let you see the branching functions clearly. The IF...THEN
statement is one of the most common BASIC statements because it is the essence of what
computer programs do, they branch based on true and false values.

Example 4 - CODES

This short program presents another example of branching while showing you how computers
store characters. In ASCII, the standard way to represent characters in all computer
languages, each character is stored as a numeric code between 32 and 127. Special codes
are between 0 and 31. Codes above 128 are called high ASCIHl and refer to special graphics
symbols. The PRECOMPUTER UNLIMITED™ supports all ASCII codes through 225. ASCII
stands for American Standard Code for Information Interchange.

10 REM ASCII CODES

REM is an important BASIC command meaning remark. As your programs get longer you
need to write comments to remind you what is going on. These comments do not affect
the running of the program. This REM statement tells the name of the program.

20 LET N=32
30 PRINT N; “ ”;CHRS$(N)

This output statement uses the Key Function CHR$ which returns the ASCIl character vatue
of N.

40 LET N=N+1
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This does not look like proper algebra but it makes sense to a computer. It means LET
the value of N be equal to the previous value of N plus 1.

50 IF N<128 THEN GOTO 30

Another example of branching. IF it is true that the value of N is less than 128 THEN
branch to line 30 and print out the next ASCIl code. If N exceeds or equals to 128 the
program will go to line 60 instead of line 30.

60 END

Example 5 - PHONE

Storing friend’s phone numbers is a common use for computers. One way to do this is
to keep the data directly in the program using the READ...DATA statements. This program
reviews much of what we’'ve learned so far while introducing READ...DATA.

10 INPUT “FRIEND’S NAME ”;NAMES$

First get the name of your friend from the keyboard.

20 NM$ — 138 2]
30 COUNT =1
40 READ TOTAL
These three statements initialize the variables. The NM$ is set to nothing, the COUNT starts

at 0 and the TOTAL number of entries is read from the first DATA line which comes after
the end of the program.

50 DO WHILE (NM$ <>NAME$) AND (COUNT <=TOTAL)

This is a powerful ioop statement that in English would say: “While NM$ is not the same
as NAME$ and the COUNT is less than the TOTAL data entries do the next statements.”
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60 READ NM$
70 READ PHONES

These statements read the next phone entry from the DATA statements below.

80 IF NM$ = NAMES THEN PRINT PHONE$

If the contents of NM$ matches NAMES then print out the phone number finked to that
NAMES.

90 COUNT = COUNT + 1
100 LOOP

Increases the number of entries checked by one. This will eventually end the DO WHILE
loop when the count becomes greater than the total number of entries. Until this occurs
the program will return automatically to the DO WHILE statement in line 50.

110 IF NM$ <> NAMES THEN PRINT “NOT FOUND”

If the inputted name (NM$) is not in the entries then print NOT FOUND.

120 END

Notice that the DATA statements begin after the END statement. This keeps your program
organized.

130 DATA 3

This first DATA statement tells how many entries there are.

140 DATA “FRED”, 693-2120
150 DATA “ROB”, 613-8162
160 DATA “RICK”, 813-8475
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These three lines contain the actual data.

You can easily add many DATA lines to your program to include quite a large number
of friends. DATA lines are not part of the sequence of the program but simply hold information.

Example 6 - AGENAME

This fun activity reviews what we have seen so far and adds a new Key Function of BASIC
called LEFT$. LEFT$ and MID$ are functions that work on strings of characters picking
characters from the left, middle of a string, respectively. This is useful when you don’t
necessarily want to get a perfect match of long strings but just to get the first few characters
to match. For example, Y could represent YES as an input.

LEFT$(Y$,3) means take the first three characters from the left of the string variable entered
by the user. Compare that to “YES” to see if the user wants to quit. LEFT$(Y$,1) would
have only compared to see if the first character was “Y”.

Example 7 - PALS

The PALS program introduces a powerful way that most computer languages store large
amounts of similar information - arrays. Arrays are a number of variables that have been
set aside with the same name yet have an index indicating how many have been reserved.
The DIM statement of BASIC reserves space in the computer for arrays of variables. In
addition to the array definition, this program introduces the powerful looping statement
FOR...NEXT. After branching, the most important thing computers do is to repeat the same
operation again and again. This is called looping.

10 CLEAR 400

The CLEAR statement clears 400 bytes of memory for the array. You can enter any number
after the clear, as long as it is large enough to hold all your information.

20 DIM PALS$(10)

The DIM statement defines the array of PAL$ to mean 11 names (0-10). In this case
the names will be of your friends.

30 REM INPUT THE NAMES

This remark statement tells you what is going to happen.
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40 FOR N=0TO 10

This begins the loop and means to set N initially to 0 and every time you go through the
loop increase N by 1 until N equals 10. When N=10 the program will jump to the next
sequential statement after NEXT.

50 INPUT PALS$(N)
Put whatever the user types into the Nth position of the array, beginning with PALS$(0).

60 NEXT N

For every FOR there must be a NEXT. NEXT means the end of the loop, increase the
counter (N) by 1, and do the loop again.

70 REM OUTPUT THE NAME TO THE SCREEN AND PRINTER
80 FOR N=0 TO 10

90 PRINT PAL$(N)

100 LPRINT PALS$(N)

Do the loop again but this time print out all the information entered previously.

Printing to a printer (LPRINT) is easily done by adding “L” to the PRINT command. |f
you do not have a printer connected to the unit, do not include this line in a program
you will RUN.

110 NEXT N

The end of the print loop that will stop when N is greater than 10.

120 END

Examples 8 (ANIMALS) and 9 (CHANCE)

These programs are true challenges. They repeat the concepts covered in the initial programs
but add more complex looping. Example 8 sorts a list of animal names while Example 9
plays a game of chance. Follow the lines through step-by-step, as we have done above,
and you will see how each program flows.
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Tip
If you are unsure of a command or function click the on-screen HELP icon, review the
Key Words list, or read the BASIC section of this manual.

CHAPTER 11 CONTROL PANEL

The Control Panel functions allow you to select how you want important features of the
computer to operate. Most of the time these features are set when you first start the
computer, however you can adjust them to suit your needs. Setting the Control Panel
functions is one of the first things to do when starting to use your PRECOMPUTER

UNLIMITED™. Double click the Control Panel icon @ on the Desktop to see the various
options.

If you should ever want to reset the Control Panel to the original settings, this can aiso
be done in the Control Panel. Once you have entered the Control Panel screen open
the File Menu. Select the blue icon. A pop-up window will appear asking you if you would
like to reset to the default settings. Click “Yes” or “Cancel”’ at this time.

CONTROL PANEL SETTINGS

Sound

The PRECOMPUTER UNLIMITED™ lets you link sound effects to various parts of the
program. These sound effects can be turned on or off using the icons in the upper left
corner of the Sound section of the Control Panel. To enter the Sound Setup double click
the SOUND icon in the Control Panel screen. A grey screen with 2 vertical boxes will
appear. The left box lists the different parts of the program to which you can attach a
sound effect. Scroll through the list and highlight the item you would like to adjust. Next
go to the box on the right. This box lists the various sound effects you have to choose
from. Highlight the sound you would like to use. Use the Test button to hear a preview
of your selected sound.
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Auto Power Off Animation

If the unit is left on but not used for about 15 minutes, the unit will turn off automatically
to save power. You can select the animation which plays when the unit auto power off.
To select an animation, click the AUTO POWER OFF ANIMATION icon from the Control
Panel screen. Next, in the box on the left of the screen, highlight the animation you want.
To see a sample of your selection click the Preview button on the screen.

You will be asked to save the new setting when you Exit the Auto Power Off Animation
screen.

Date/Time Setting

To setup the Date and Time settings of your unit, select the DATE/TIME icon on the Control
Panel screen. A blue screen showing the month, year, date, and time will appear. Click
on the item to be changed (you can use the keyboard shortcut keys as well: ALT+M =
Month, ALT+Y = Year, and ALT+T = Time) and enter the new data. Be sure to press ENTER
before leaving a changed data box or the information will revert to the default. However,
once the new settings are saved they will remain until you turn off the computer.

Note: For certain applications, for example the Daily Planner, your data settings are
important. Remember to set your Date and Time settings accurately.

Mouse

Access the Mouse Setup screen and you will see the numbers 1-5 across the screen. The
speed of the mouse can be adjusted either faster or slower. In the slower settings (1 &
2) the mouse is less active. This maybe good if you are new to using a mouse or drawing
a detailed picture. The faster settings (4 & 5) allow the cursor to travel a greater distance
with less movement of the mouse. This is for advanced users or fast-paced activity. The
default setting for the mouse is the middie speed (3).

You will be asked to save the new setting when you Exit the Mouse Setup screen.
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Printer

The PRECOMPUTER UNLIMITED™ supports a number of different printers for output. To
set the unit to support your printer, select the PRINTER icon from the Control Panel screen.
Next, highlight the type of printer you have and then press ENTER. If you do not see
your printer listed, highlight the selection that your printer is most compatible with.

You will be asked to save the new setting when you Exit the Printer Setup screen.

Memory

Memory on any computer needs to be watched and managed. The PRECOMPUTER
UNLIMITED™ lets you check your memory allotment at any time. After selecting the
MEMORY icon from the Control Panel you will see 2 bars appear on the screen. The
top bar represents the main unit's memory; the bottom bar is the optional RAM cartridge.
(The bottom bar will only light up when the RAM cartridge is installed.)

If you have no file stored the entire main unit bar should be yellow. As you save files
the bar will change from yellow to blue. When the blue line has moved from the left side
of the screen all the way to the right, your memory storage area is full.

If you run out of memory, you can either use a RAM expansion cartridge or delete some
files from the main unit memory. Pictures take up more memory than text. Printing or
deleting one Art Studio file can free enough memory for a number of Word Processing
documents.

CHAPTER 12 DAILY PLANNER

Daily Planner is one of the most helpful tocls in computers and organizers. The Daily
Planner application in the PRECOMPUTER UNLIMITED™ helps you keep track of birthdays,
anniversaries, parties, project assignments, sporting events, and many other activities.

The Daily Planner is related to the Date/Time setup, so it is important that you enter today’s
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information in the Date/Time Setup before beginning to work in the Daily Planner. Go to
the Control Panel to find the Date/Time module.

HOW TO BEGIN

Double click the Daily Planner icon Eg on the Desktop. The monthly calendar will appear
on the screen. The first place to look is at the information bar near the top center of
the calendar.

1 - 1997 (1:364) 1

The first two numbers represent the month and year. The numbers in parentheses tell which
day of the year this is and how many days are left until the end of the year. The last
number tells which week this is of the year. These numbers can help you when working
on long range projects.

When the Daily Planner opens for the first time there is no information listed for any dates.
Any information you enter into the Daily Planner must be saved in a file. If you have
already saved data into your calendar, load that file from storage.

MENU BAR
File Menu |~ ||

This menu functions as described in the Chapter 5 (HOW TO BEGIN) section of this manual.
Please refer to that area for details.

|3

There are two kinds of information that can be entered into the Daily Planner - stamps
and text. Stamps indicate graphically what kind of an event is happening, these will appear
in the Monthly and Weekly view. Text is the information you type in about an event. Text
will only appear in the Weekly view.

Edit Menu

To place a stamp on a date, click on the date. This causes that date to be highlighted.
Next open the Edit Menu and select the STAMP icon. A dialogue box with the various
stamp options will appear. Click on a stamp and it will appear on the date you had selected.

Entering text information is done in the Weekly view. Click on a day and the editing cursor
will appear in the date box. Type in your information.

The third icon under the Edit Menu is the Clear icon. By highlighting a date then selecting
this icon you clear the entries on that date.

« "

As you work in the Daily Planner you will move back and forth between the weekly and
the monthly view. The Monthly view gives you an overview of events but you cannot see
the details you have written. The Weekly view gives the details of the events. Click on
the View Menu to choose between these two options.

View Menu
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Format Menu |* @

When starting your calendar, you probably need to first set how you want your weeks to
appear. Your weeks can run Sun - Sat or Mon - Sun. Open the Format Menu and click
on the weekly format icon you prefer.

Search Menu |* @

The Daily Planner has a special option for quickly getting to your date of interest. Use
the Search Menu to find a certain date. After selecting the Search Menu choose the FIND
icon.

Select & format and enter

the date.
4 MM=00=YY ¢ DD-MM-YY

01 |01 [B-frs32 [

les | Cancel

Use the scroll bars in the FIND dialogue box to move to any date in the calendar. Dates
allowed go from 1901 to 2099. To help you with history you could list major events of
the past to see how they relate in time and to help you remember what happened when.

The forward and backward buttons on the Search Menu move the calendar by day, week,
month or year in either direction.

The Daily Planner is easy to use and a practical tool to manage your activities and events.

CHAPTER 13 DATABASE

A database is an organized way to manage information. A telephone book or a membership
list are both databases. When we put information into a computerized database we expect
to be able to process that information easily, whether we are searching for information,
adding up totals, or seeking the highest value in any category. Databases can sort
information or search through a huge coflection of information looking for specific information.
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Simple databases are contained in files that are just like a file in a coach’s desk. Within
the file there are a series of records that could be forms that are filled out. On each form
there are a number of fields that actually contain the information. A coach might have
a database of team members. The database might contain records with a number of
fields containing information on each player’s name, address, and phone number.

Before developing a database on a computer, several issues need to be thought of ahead
of time.

1. What is the purpose of the database? What information am | hoping to find?

2. What information do | need to store? Databases don't usually store all the information
on a topic. For example, a coach does not have a database of every athlete in the
world, just the members of a specific team.

3. What kinds of reports do | need to generate? Databases are only useful if they can
generate helpful reports. In other words, what information will | want out of the database,
and how should it be formatted? A coach may want a list of every player’s guardian
so a permission slip can be sent home. A database could provide this if the information
existed in a field.

4. What are the important index fields? Databases maintain their information in a particular
order. Choose the best order for your database.

5. Do | have the time to enter the data and keep it up-to-date? Don't pick something too
detailed, like every homework assignment you are given. This will be too hard to maintain
and the benefit of having a database will be lost.

A common database is a database of your friends’ addresses, phone numbers and some
special information like a birth date. We will create a sample database called FRIENDS
that has a record for each friend and the following fields of information.

Last Name, First Name, Street, City, State, Zip, Phone Number and Birth
Date.

The steps we will take are: Design the database, enter the information, create a report
and, of course, save the database to a file. The Database application in the PRECOMPUTER
UNLIMITED™ will make each step easy and quick.

DESIGNING THE DATABASE

At the Desktop menu click on the Database icon in the Computer Skills section.

The first step of working with a database program is the creation of the actual database.
Let's use our sample FRIENDS database as we work through the steps.
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Click the FILE menu and select NEW [ ¥

The design form should appear on the screen. The design form is made of 6 columns
labeled No., Field Name, Field Type, Width, Decimal and Index. The number row will increase
by one automatically each time you hit enter, so you do not need to worry about that column.
For all the other columns you will be entering information into their rows. Once information
is entered into all the necessary columns in a row this row is called a field.

The Field Name must be one word that describes the data to be stored there. The Field
Type can be any of the following: Character, Numeric, US-Date, UK-Date or Logical. If
you choose Numeric for a Field Type then the Decimal field is available to say how many
digits will be displayed after the decimal point. This is useful when dealing with currency
or scientific calculations. If you do not choose a Numeric Field Type, the Decimal field
will remain empty.

The Index column allows you to indicate whether or not this field will be sorted. Sorting
is how you can access information in your database. The most common type of sorting
is alphabetical based on last name. To decide which field will be sorted insert a “Y” for
yes or “N” for no in the Index column. In each record you can only sort based on one
field. If you enter “Y” in any Index column all other Index columns will change to “N.”

Take a few minutes to enter the fields of our FRIENDS database. When done your screen
should look something like this:

LastName | Character
firstName | Character
Character
Character
Character
Cheracter
Character

|3 (e | D

No. Field Name Field Type Width Decimal Index
1 LastName Character 20 Y

2 FirstName Character 15

3 Street Character 25 N

4 City Character 20 N

5 State Character 2 N

6 Zip Character 10 N

7 Phone Character 10 N

8 BirthDate US-Date 10 N
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The character type can be changed by pressing the space bar when the cursor is on that
field or by pressing C - Character, N - Numeric, L - Logical, S - US-Date, K - UK-Date.
The maximum length for a character field is 80 and the maximum length for a numeric
field is 20. Date fields are set to 10 and logical fields (True/False) are always 1 character.

In this database it is not necessary to have any Numeric fields. Although we will be entering
numbers, none of the numbers will have decimal points. So we can enter them as characters
and save the memory of the Decimal field.

After entering the field data it is a good time to save your database design. Click File
then click the Save As icon. Select where you would like to save the file (main unit or
RAM Cartridge) and name FRIENDS. When working with a database it is a good habit
to save often. Data entry is time consuming and you don’'t want to lose your work.

ADDING AND DELETING FIELDS

A powerful feature of the PRECOMPUTER UNLIMITED™ is the ability to insert a field in
the design. Choose the field directly below where you would like the new field to be placed,
from the Edit Menu choose Insert Field. A new field will be inserted above the chosen
field. Deleting a field is just as easy. Highlight a field and then choose Delete Field from
the Edit Menu.

ENTERING DATA

After the design has been created and saved, you can start to enter data by selecting
the Input Record icon under the Edit Menu. A pop-up dialogue box will appear asking
you to confirm that you want to enter data. Click “Yes”. Next a blank record with your
field names displayed will appear. It is waiting for your input.

First Name
Street

City

Slate

Zip
Phone

The bottom of the input screen gives some information about the database. At the bottom
left of the screen you will see the title of your database (this will be the name you used
to save your file). At the bottom center of the screen is a counter telling you which record
you are looking at and how many total records you have. The bottom right of the screen
will indicate if the CapsLock, INSert or NumLock options are activated.
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Now look at the large box in the center of the screen. Notice the up and down arrows
on the right of the record. These are navigational arrows that will allow you to go easily
from one record to another in the database. They will not go beyond the last record where
you have entered data. As you scroll through your records the record indicator at the
bottom center of the screen will indicate which record is being viewed. You can also use
the Page Up and Page Down arrows to move between records.

Experiment with these options by entering a few records. Use the arrows to move between
the fields. Always remember to save your work when done.

GO TO AND SEARCH

The Edit Menu has several nice features for locating records in a large database. This
is easier than scrolling through every record in a large database. For example, GO TO
calls up a dialogue box asking for the record number you want to access.

Use the arrow keys to select a number and click on the YES button to call up the requested
record.

Another tool is the Search feature. Click on Search icon under the Edit Menu and you
will be asked to enter a word that the computer will lock for in any field of the database.
Notice that the program will look for exactly what you enter so make sure you get any
punctuation correct.

If a matching record is found that record will appear on the screen and the user will be
asked if the program should search for another record or not. Click on Next button or press
ALT-N to continue looking for the next match.

Once a record has been retrieved you can go to any of the fields and edit any information.
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RECORD MENU [ |+

Computers are at their best when asked to sort information. This means you can enter
information in any order then rely on the computer to organize it. This process is called
Sorting. Use the Sort item under the Record Menu to organize or sort, the records are
based on the priorities you gave the program when designing your form. The program
will sort the Indexed field. It will always ask if you want to sort in ascending (A-Z, 1-
10) or descending (Z-A, 10-1) order. For instance, the LastName field of the FRIENDS
database will normally be the field used to sort your records. If you Indexed this field
and sorted in ascending order, the program would look at every entry in the LastName
box and sort them alphabetically A-Z. It would also change the numbers of all the files
so the one closest to AAA would now be record 1 and the last record will be the one
closest to ZZZ.

You do not need to sort only alphabetically. By indexing the Phone or Zip field you can
sort by number as well. You can change the indexed field at any time in your form.

The Record Menu offers several features for managing your database. You can mark a
record and unmark a record. If a record is marked an asterisk appears on the tab at
the top right of the fields. The purpose of marking records is to have a different way
of sorting them. For example, on your FRIENDS database, you could mark all friends
who attended your party last week. Then you could print out this list so you know where
to send your thank notes. Or perhaps you want to print out all those who didn’t attend
your party so you can invite the second group to next week's party. Using the Marking
feature gives your printouts more flexibility.

Also choose the Record Menu and the Delete Record item to delete the current record.
A dialogue box will ask you to confirm the deletion of the current record.

REPORTS

The purpose of a database is to provide you with information easily and quickly. That
is why the Report feature of database programs is so important. Basically a database
Report is what you would call a printout. !t is a hard copy of the information you entered,
in the order you sorted it. You can give your report a title by choosing the Heading item
of the Report Menu. The heading can have a maximum of 20 characters. It should tell
others what the report is about. In the example above, the title might be Last Week’s
Party.

Reports are based on a query of the database. That means you ask a query of the database
to select certain records for your use. A Query is very similar to a Sort, but the Query
results are printed while the Sort results are on-screen. Choose Query under the Report
Menu and the following dialogue box appears.
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This means you can create a report of all Marked Records, Unmarked Records or All
Records. If you want to do a more sophisticated report chocse the Options command and
a new dialogue box will appear.

This rather complicated screen has three fields to complete. You need to enter the field
name you would like to query, then enter the condition of the query, finally enter exactly
what you would like the program to look for. For example, if you want to choose all friends
whose last names begin with L or any letter after L follow these steps.

Enter the field name as LastName

The condition should be > = to indicate you want to choose those records with a last name
greater than or equal to something.

String refers to the specific name the value for the comparison, in this case L.

After completing the three boxes and confirming your choices, the reports will appear
immediately on the screen. Printing them to paper requires choosing the print function
from the File menu.

The PRECOMPUTER UNLIMITED™ Database program has many of the standard features
of larger desktop database programs with an ease-of-use that makes design and management
of a database understandable.

CHAPTER 14 €QUATION MAKER

In this activity, you need to use your math skills to construct a correct equation from the
scrambled numbers and operators.
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HOW TO BEGIN

Double click the Equation Maker icon 93 in the Desktop. A disordered equation will

appear on the screen. You must rearrange the numbers and operators to form a correct
equation.

Double click on the number or sign you think is first in the equation. Repeat the same
process for the second and third items. Continue this process until all the numbers and
operators have been selected. If you make a mistake, you can use the Backspace key

or click the { icon to undo the last selection. When you think you have correctly

arranged the equation, click the

icon to have the unit check your answer.

Menu Bar

This menu functions as described in the Introduction section of this manual. Please refer
to that area for details.

File Menu

Level Menu f‘" Ej

This activity allows for 4 levels of challenge. To change the level at any time open the
Level Menu and select the icon (1-4) which corresponds to the level you desire.

Player Menu [‘;J @

This activity allows for 2 modes of play - 1-player and 2-player. In the 1-player game
there are 3 chances for you to create each equation. In each chance, you have 1 minute.
If you create a wrong equation or run out of time you will lose 1 chance. When all three

chances for an equation are gone a new equation will appear. If you use the

no points will be awarded. At the end of each round you will be asked if you want to
continue. If you earn perfect scores in two consecutive games, you will be promoted to
the next level of difficulty.
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n 2-player mode, the player who presses his/her Player key first earns the right to try to
solve the equation first. If the first player fails to create a correct equation, the second

player gets a turn to try. The second player can solve the equation or click the

button to skip the equation. When a round is finished, the player with the higher score
wins. If the players have the same score, the game is a draw.

Option Menu L]

This is where you can turn the sound on or off. Open the Option Menu then select the
appropriate icon.

If you are confused, open the Help Menu for a list of terms which apply to the Equation
Maker activity.

Scoring

1-Player Mode

Questions per round 5
Correct answer on the 1st try 20
Correct answer on the 2nd try 10
Correct answer on the 3rd try 5

2-Player Mode

Questions per round 5
Starting Score 100
Correct answer

1st player 20
2nd player 10
Wrong answer

ist player -20
2nd player -10

CHAPTER 15 EXPANSION CARTRIDGES

The PRECOMPUTER UNLIMITED™ allows for the use of expansion cartridges for extended
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learning value. The two cartridges that come with the main unit cover Geography and
Science.

INSTALLING THE CARTRIDGE

1. Make sure the unit is OFF.

2. insert the expansion cartridge, label facing up, into the cartridge slot on the left hand
side of the unit. (You should feel the cartridge click into place.)

3. Turn the unit ON.

4, Double click the EXTERNAL icon

in the Desktop.

5. In the External screen, double click on the Cartridge icon

When the expansion cartridge is inserted, the text of the Cartridge icon will turn to biack.
This indicates that there is a cariridge inserted and you can now access it.

HOW TO BEGIN

When you click on the Cariridge icon a pop-up window will appear showing the topics
available in the cartridge you have selected. Click on a topic and ciose the pop-up window.

For details on game play see the Trivia section of this manual.
Tip
If the cartridge is not inserted properly the word “Cartridge” will not turn black when you

click on the Cartridge icon at the External screen. Turn the unit off and try to reinsert
the cartridge.

CHAPTER 16 EXTERNAL (COMMUNICATION)

The Communication application lets you link the PRECOMPUTER UNLIMITED™ with a PC
and another PRECOMPUTER UNLIMITED™. With this feature you can transfer files for
greater storage.

Notes:

1. To link the unit and a PC you must install the floppy disk labeled “POWER LINK™"
onto your PC. Please see the POWER LINK™ INSTALLATION section in the Chapter
2 of this manual for further details.

2. To link two units you must have Unit-To-Unit cable (Not Included).
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PRECOMPUTER UNLIMITED™ AND PC HOOK-UP

PC and PRECOMPUTER UNLIMITED™ Connection.
1. Make sure the unit and the PC are OFF.
2. Select the POWER LINK™ cable from the packed in materials.

3. Insert one end of the cable into the jack labeled “PC LINK” on the back of the
PRECOMPUTER UNLIMITED™ unit.

4. Connect the other end of the cable into the serial port of your PC.
5. Turn the unit and the PC ON.

Note: For details of connection see the Chapter 2 Hook-up and Connection.

HOW TO BEGIN

Make sure your unit is properly connected to your PC. Double click the EXTERNAL icon

in the Desktop. Next you will see a screen with 2 more icons - Communication

and Cartridge. Double click COMMUNICATION icon g%

File Transfer

To Send a file, open the Utility Menu. Then select the SEND FILE icon. Designate if the
file you will be sending is found in the Main Unit or a Cartridge. Next designate the folder.
Finally, highlight the file you would like to transfer then click “Yes”.

To Receive a file, open the Utility Menu. Click the RECEIVE FILE icon. Designate if the
file you will be receiving should be sent to the Main Unit or a Cartridge. Next designate
the folder. Finaily, type in the name you would like the file to have when your computer
receives it then click “Yes”.

You can stop sending or receiving a file at any time by clicking CANCEL during transfer.

Chatting

After clicking the COMMUNICATION icon you will see a screen with 3 horizontal boxes.
The top box has a yellow monitor next to it. This box will show messages you have received.
The box next to the blue monitor will show messages you are typing before you send it
out.
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PRECOMPUTER UNLIMITED™ AND PRECOMPUTER
UNLIMITED™ HOOK-UP

1. Make sure the units are OFF.
2. Select the Unit-To-Unit cable (Not included).

3. Insert the cable into the jack iabeled “PC LINK" on the back of the PRECOMPUTER
UNLIMITED™ unit.

4. Turn the units ON.

Note: For details of connection see the Chapter 2 Hook-up and Connection sections of
this manual.

After the process is completed, you can perform the File Transfer and Chatting.

Notes:

1. If the file to be transferred is larger than the remaining memory of the receiving unit,
there will be an error message on both units and no transfer will take place.

2. During file transfer, if any user wishes to stop the transfer, some stray data will appear
on the screen. To remove the stray data, please restart the system.

CHAPTER 17 FILE MANAGER

Learning to manage your memory space and documents is an important computer skill.
Wise computer users skillfully organize their hard drive space so they have room for new
files, as well as making sure that all documents have logical names and are stored in related
folders. The File Manager provides the tools you need to master these skills.

HOW TO BEGIN

Double click the FILE MANAGER icon &5 in the System section of the Desktop. You

will see a screen showing two icons (Main Unit and RAM Cartridge) and a Menu Bar across
the top of the screen. The cursor will default to highlight the Main Unit icon. You can
use any of the tools available in this Menu Bar, or you can skip these tools and proceed
to the Folder Screen.
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MENU BAR

File Menu @

In the File Menu there are 2 icons, - Open and Exit. Click the OPEN icon to tell the
computer to open the memory area you have selected (you can only select Cartridge if
you have the RAM cartridge installed - sold separately).

Click the EXIT icon to leave the File Manager and return to the Desktop.

Edit Menu

ALT ‘1 e
— i ‘

In the Edit Menu there are 2 icons - Format and ScanDisk. Click the FORMAT icon to
erase all the files from your hard disk. This will not affect any of the unit's programs,
but it will delete all user created files.

Click the ScanDisk icon to have the unit check for “bad” spots in the unit's memory. These
would be areas that the unit cannot write to because they have become damaged. If the
scan encounters no problems a pop-up window will appear to confirm that the task has
been completed.

Help Menu |~ |||" |

Open this menu to access the help files.

FOLDER SCREEN

To get to the Folder Screen, click the Main Unit icon. (If you would like to perform the
following tasks on a cartridge click on the Cartridge icon instead of Main Unit) The Folder
Screen shows a Menu Bar and any folders you have created. |If this is your first time
to the Folder Screen the only folder present will be “User”. You can use any of the tools
available in the Menu Bar, or you can skip these tools and proceed to the File Screen.

MENU BAR
o @

In the File Menu there are 3 icons - New, Open, and Exit. Open functions the same as
described above.

File Menu
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The NEW icon allows you to create a new folder. When you click NEW, a pop-up window
will appear. Type in the name of your new folder and click “Yes”. The new folder will
appear next to “User” in the Folder Screen.

Click the EXIT icon to leave the Folder Screen and return to the File Manager Screen.

Edit Menu |« |||

There are 2 icons under the Edit Menu - Rename and Delete. These tools can be used
on any folder you have created. They cannot be used on the “User” folder. If you have
multiple folders created, highlight the name of the folder you would like to modify for selecting
one of these icons.

Click on RENAME. A pop-up window will appear. Type the new name of your folder in
the “To” text box and click “Yes”.

Click on DELETE. A pop-up window will appear. Click on “Yes” to confirm that you would
like the selected folder deleted. If you delete a folder you will lose all the files in that
folder as well.

HicH
ALT 1 !
i

Help Menu

Open this menu to access the help files.

FILE SCREEN

In the Folder Screen double click on any folder icon to enter the File Screen of that folder.
When you enter a folder's file screen, you will see an icon for each file you have saved
to that folder. The application which the file is associated with will be indicated by the
design of the icon. For example, a Word Processing file icon will be different than a
Spreadsheet icon.

MENU BAR

The File Menu has 2 icons - Open and Exit. Open functions the same as described above.

Click the EXIT icon to leave the File Screen and return to the Folder Screen.
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Edit Menu ||v B

There are 4 icons in the Edit Menu. They are Rename, Copy, Move and Delete.

Click the RENAME icon to change the name of the selected file.

Click the COPY icon to send an exact replica of the selected file to another folder. The
unit will prompt you to confirm the folder you would like the replica to enter.

Click the MOVE icon to transfer the selected file from one folder to a different folder. No
copy of the file will remain behind in the original folder. The unit will prompt you to confirm
the folder you would like the file moved to.

Click the DELETE icon to remove a file from your system’'s memory. A pop-up window
will appear to confirm. Click “Yes” if you are sure you want the file deleted. Once a
file is deleted it cannot be recalled.

Help Menu |*

Open this menu to access the help files.

Note: 29 files can be stored inside the User folder. 30 files at each other folders.

CHAPTER 18 FLOWCHART TUTOR

Flowcharts are a big part of programming. They are a road map which tells you how
a program will flow when executed. Because they are a visual representation of a program,
flowcharts can clarify the flow of a program for you. The Flowchart Tutor in the
PRECOMPUTER UNLIMITED™ contains flowcharts which correspond to the Sample
Programs in the BASIC Tutor application.

HOW TO BEGIN

<y

Double click the Flow Chart Tutor icon & E from the Desktop. Open the View Menu.
From the View menu choose the Flowchart icon. A dialogue box will open with the BASIC
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keywords. Choose one of the keywords to open a sample program with a flowchart illustrating
the keyword.

Tip
Look at the different shapes of the boxes in the flowchart. Each box means a different

instruction. For example, a diamond shaped box indicates a decision or potential branch
in the program. Can you identify other box shapes and what they mean?

CHAPTER 19 MELODY MAKER

The Melody Maker application of the PRECOMPUTER UNLIMITED™ allows you to compose
songs with a variety of instruments which the computer will play back. You are able to
pick which instrument plays each note. After composing a song, you can edit your work
or save it to the hard drive for future listening or incorporation into a Report Writer
presentation.

HOW TO BEGIN

Double click the Melody Maker icon @ on the Desktop to open the application.

When you enter the activity, you should see a screen with a menu bar across the top,
a toolbox on the left, and a large white box with a staff and controls taking up the rest
of the screen. The toolbox has eight options. To access any option, click on that tool.
You will retain that tool until you pick a different one.

Use this tool to move to different locations in your compositions.
Use this tool to erase a note once it is placed on the staff.
Use this tool to place pauses in your composition

Use this tool to place piano sounds in your composition.

Use this tool to place horn sounds in your composition.

Use this tool to place bell sounds in your composition.

Use this tool to place drum sounds in your composition.

Use this tool to place car sounds in your composition.
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The main work area of the screen resembles a typical music staff with a time signature
of 4/4. The horizontal lines make up the staff, this is where you put the notes. Click
on the staff to place a note from the instrument you have selected. Remember that the
higher you put the icon on the staff, the higher in pitch the note will sound. If you do
not know music, here are the tone values of each line in the staff:

A mr*mﬂ
q .
bl

Composing a tune with the Melody Maker is done by clicking on toolbox instruments then
clicking on the staff at the desired location. A small icon representing the instrument selected
will then appear on the staff. Listen to how each instrument has an individual sound and
duration. After the song has been created you can play it using the blue Control icons
below the staff.

Beneath each control include the following descriptions as a break out box.

—t

. Play the song again and again (loop)
Go to the first note of the song

Play the song

Go to the last note of the song
Stop

Pause

N o g M wDn

Scroll within the song

At the bottom of the screen are golden phonographs which animate to indicate which note
is playing as the song plays. Like a piano, the higher notes are further to the right.

B

EDITING A SONG

Just like with Word Processing, the power of the computer becomes apparent when you
want to change or edit your song. You don't have to rewrite the song - just use computer
commands to delete, add, or cut and paste parts of the song.

The easiest task is to delete a note and enter a new one. To delete a note click on the
Delete Note tool, then click on the note you would like to delete. The note should instantly
disappear leaving you free to place a different note in that spot. To enter a new note
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without using the Delete Note tool, select an instrument. Next go to the place in the song
which you would like to edit. Click on the existing note and a new note will take its place.
You do not need to replace a note with a note of the same tone; clicking anywhere in
the column will be sufficient.

Editing a block of notes is done by first selecting a block, cutting that block of notes then
pasting the block wherever you desire. Choose Select Block from the Edit Menu. A dialogue
box will ask you if you want to select “By notes” or “By measures”. If you choose “By
notes” the cursor will change into a left bracket [ Use the mouse to click on the place
where you would like to begin editing. The cursor will then change into a right bracket
. Use the mouse to place the right bracket at the place where you would like to stop
editing. Next choose Cut from the Edit Menu to erase the selected block from the screen
and place it into the memory buffer. Finally place the cursor where you would like the
cut passage to belong and choose Paste from the Edit Menu to paste the notes in the
new location.

If you choose “By measures” another dialogue box will ask you which measures to select.
Enter the measures by number, for example 3-6. After you enter the measure numbers
and click “Yes”, the chosen measures will be highlighted. Next choose Cut from the Edit
Menu to erase the selected block from the screen and place it into the memory buffer.
Finally place the cursor where you would like the cut passage to belong and choose Paste
from the Edit Menu to paste the measures in the new location.

This technique is helpful if you want to repeat a series of notes or measures many times
in your song.

The last Edit command is to Clear Notes. Choose this command to start over with a blank
music worksheet.

INSERT MENU [~ _

Opening the Insert Menu brings up 4 icons. Each one represents a different, built-in song.
This option allows you to choose a sample song to see how the Melody Maker works.
Click on one of the song icons and then click the blue Play button to hear the song.

You can edit the built-in songs as described above, but if you try to save the changes
you will need to save them under a different name. You cannot alter the permanent memory
of the unit.

MUSIC MENU

The Music Menu offers two options - changing the time signature and changing the tempo.
If you click on the Time Signature icon, you will see a dialogue box with three options:
4/4, 3/4 and 2/4. 4/4 is the default signature. The 3/4 time has three beats to a measure
and is a common waltz tempo. The 2/4 time has only two beats to a measure. Time
Signature does not affect the tempo or speed of a song.
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If you click the Tempo icon you will see three options: Slow, Middle and Fast. Click on
any option then click “Yes” to confirm. Use one of the sample songs to try each of the
tempos to hear how it can affect the same song.

"]

VIEW MENU [~ ]

The View Menu allows you to place a single staff or the treble and bass clef together
on the screen. When the double staves are on the screen the animated note-following
icons do not appear.

The Melody Maker program is a beginning program to help students get the idea of how
it is possible to compose a tune and record it on a computer to play again and again.
Musical creativity is not just for a few highly trained composers but can be appreciated
and achieved by everyone.

CHAPTER 20 MEMO PAD

A Memo Pad is a place to jot down notes that you want to keep handy. Similar note
taking devices are common in many organizers. The Memo Pad in the PRECOMPUTER
UNLIMITED™ also offers you a special drawing feature.

HOW TO BEGIN

To open the Memo Pad application, double click the Memo Pad icon &g on the Desktop.

When you open the Memo Pad, you will see two areas: a Writing Area and a Drawing
Area.

Writing a Memo

To use the Writing Area, click in the area or press ALT-N on the keyboard. The amount
of text you can type is limited by the size of the space on the screen. There is no scrolling
in this application, but you can get more space by clicking the page arrows in the lower
right of the screen. All the common editing keys can be used to edit the note.

Drawing a Picture

To use the Drawing Area, click on the area or press ALT-D on the keyboard. A black
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pixel will appear in the upper left corner of the Drawing Pad. You draw by holding down
the left mouse button and moving the mouse on the screen. You can aiso choose a spot
and press the space bar to create a black pixel. Remember though that you must hit
the space bar and arrow key for each picture. Just holding down the space bar will not
work. You can only draw in black. Move the mouse slowly to draw a solid line.

Multiple Memos

When you are done with one memo, you can add another by clicking on the right arrow
button on the lower right of the screen. The Memo Pad can store up to 5 memo pages
in one file. If you need to have a large number of notes, you have to begin a new file.
Erasing Memos

Use the EDIT function of the Memo Pad to erase a memo. This clears the screen and
allows you to start over. Be sure you are on the screen you want to clear before erasing.

CHAPTER 21 PHONE BOOK

The Phone Book application in the PRECOMPUTER UNLIMITED™ is a practical tool for
organizing how you can contact your friends, family, co-workers and fellow students. For
people working in companies and schools, this is one of the most popular organizer features
of computers. Think of the Phone Book as a series of index cards with important information
about every person you want to contact. Each card is called a record and each item on
the card is called a field. A computerized version of a phone list enables you to easily
add and modify numbers, search quickly for a number and print your list to take with you.

The PRECOMPUTER UNLIMITED™ has a complete version of a phone book, including
the following fields:

Name

Phone Number
Address

Fax Number
E-mail Address

Other Information

HOW TO BEGIN

Start the Phone Book application by clicking on the Phone Book icon on the Desktop.
The application starts with a blank record.
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ENTERING CONTACT INFORMATION

On the top right of your screen, under the title bar, there are two very important icons
- create and modify. By clicking on these icons you can change the mode of the program

from creating a new record to modifying an existing record which allows you to

view the records . By clicking on the Create a Record icon, the cursor moves to the
name field and is ready for you to input information. The Phone Book program will keep
the records sorted by the name field so it may be to your advantage to enter the person’s
last name first followed by a comma then the first name. (i.e. Smith, John). The name
is the only required field in each record. If you enter all the other information, but not the
name, the record cannot be saved.

Enter all the information you have on your contact and then click on the Create a Record
Ilcon to save that record and return to the view record mode. Clicking on the Create a
Record Icon again will generate a new blank record. You will know when you are in the
view record mode when the directional arrows appear around the list name.

These arrows will move you from record to record in the Phone Book. At any time you
can click on the Modify a Record icon to edit any field. Remember you can also move
from field to field using the TAB key on the keyboard.

If you have a large number of contacts you can keep several lists active, for instance Family
and Friends. Before entering a large number of contacts you should decide whether you
want to keep them all in one list or in several lists.

The Save button is located under the File Menu. The Phone Book is a specialized form
of a database so please remember to save early and to save often. It takes considerable
time to locate and enter contact information. Don’t waste time by forgetting to save your
work!
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MENU BARS

)

ALY

File Menu

7]

The standard File Menu options are also available in the Phone Book program. A Phone
Book file contains many phone records. Most people will have only a few files of phone
numbers and many will choose to only have one. Opening the phone number file, saving
the file and printing the file will be the most used options of the File Menu. As with the
other programs, the meanings of the File Menu icons are clearly labeled in the text box
to the right of the icons.

ALT

Phone Menu

i
The Phone Menu has only two items - duplicate and clear records. The Duplicate icon
allows you to make a copy of the current record. This might be useful if you have several
friends in the same family. The Clear icon erases the current record from the file. A dialogue

box will ask for your confirmation before deleting an entry.

Search Menu ‘Li‘

The Search Menu offers three kinds of searching commands. The Search A method

focuses only on the name field and asks for the first character of the name. The comput
retrieves the first name beginning with that letter. By clicking on the arrows or pressing
Page Up or Page Down you can move between the records until the correct name is found.

The Search AB method (B8 searches all fields of each record for 8 characters of information

entered in the dialogue box. The Search A + B method |gllf searches the name field and

L
then all other fields for 2 groups of information each with 8 characters anywhere in the
record. If more than one record is found with the information, use the Page Up and Page
Down keys to move between the records. If no records are found matching the criteria,
a message box will appear saying that no matching records can be found.

You will know that you are looking at the result of a search command when you see the
* in the File Title field. The number 2/10 * would mean you just performed a search that
found 10 matching records and you are currently looking at the second matching record.
Only matching records will appear when clicking on the arrows or pressing Page Up or
Page Down.

Password Menu L.LJ' 3

Confidential information can often be a part of a phone list. The PRECOMPUTER
UNLIMITED™ provides the capability to add passwords to each Phone List. The first icon

% adds a password to the list. After a password has been added a “lock” ﬁ will appear

in the List Name box. The Change Password icon |#8] allows the user to change the password

but first the original password must be entered. Te third option is to remove the password.
Again the user must enter the original password to complete the operation.
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Help Menu ‘! @

The Help Menu provides many useful reminders for using the Phone Book program. After
choosing the Help Menu use the arrows to scroll to and select the desired function.

CHAPTER 22 REPORT WARITER

The Report Writer application is one of the most creative applications in the PRECOMPUTER
UNLIMITED™. In recent years a number of presentation tools have appeared with software
suites and they have been extensively used by business people and educators to visually
present information to students, clients and conference attendees. Now students of all ages
will be able to present information visually in a slide show format using the Report Writer.

HOW TO BEGIN

Double click the Report Writer icon 1l on the Desktop. Think of each screen in the

Report Writer as a slide in a slide projector. Your job is to prepare a series of slides to
present your topic. Many people use a program like Report Writer to prepare a visual outline
of their ideas which are then blown up on a big screen for others to see. Then the speaker
can use the outline to organize his or her comments. The fact that the PRECOMPUTER
UNLIMITED™ plugs easily into any TV allows you to prepare a report on the computer,
take it to school and plug into a school TV for a presentation to the class.

Planning

Before creating a report using Report Writer think about how your ideas are to be organized.
As an example, let's create a simple 4 slide presentation on how to use Report Writer.
Presentation programs are great for creating tutorials on most any subject. Our slides will
have the following themes:

1. Title Siide

2. Gathering Information

3. Adding Special Effects
4. Presenting the Show

By preparing these slides we will show most of the features of the Report Writer program.
As with all information programs, it is important to remember the saying we've repeated
again and again, “Save early and save often”.

Slide 1 - Title Slide

Upon starting Report Writer the screen is blank; it is waiting for you to add objects. This
is different from a word processor where you just type and new screen appears as you
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need them. With Report Writer each screen must be laid out with text or graphic objects.
Let's set up our Title Slide:

1. First click on Insert Menu and choose the Text icon. Move the cursor to the center of
the screen and click once where you want the upper left-hand comer of the title text
frame to appear. Then move the cursor to the lower right of your text frame and watch
the text frame being created. When satisfied with the frame size, click again to activate
the text frame, which allows you to type.

2. Choose the Font Menu and select a font by clicking on the icon. We recommend the
LARGE BOLD font for this example. Push the CapsLock key on the keyboard and
type “Report Writer” in the text box. Click on the lower right of the text frame to move
the title frame to the top center of the screen.

3. Choose the Format Menu and click on the Background icon. This will pull up a dialogue
box with various options for the background. Select one and watch as the background
fills with your selection.

4. Finally let’s put a clip art graphic under the title frame. Select the Insert Menu and then
the Clip Art Icon. Another dialogue box will appear with the names of all the available
clip art pictures in the computer. You can choose any graphic, but for now scroll down
to BOOK and select it. The book clip art will appear on the screen. Click and drag
the picture until it is directly under the title text frame.

The resulting slide should look something like this.

R b il by

Report Writer

You know what to do next! Save your work to a file on the computer using the File Menu.
if you forgot how to do this, you can always refer to the File description in the Chapter
17 Folder section of this manual.

Slide 2 - Gathering Information

To insert a new slide click on the Insert Menu and select the Insert After icon. This will
place a new blank slide after the title slide. Notice that the slide counter at the bottom
of the screen tells you how many slides are in the presentation and which slide you are
now editing. 2/2 means there are 2 slides totally and we are on the second slide. Put
together the second slide following these steps:

1. Change the background to match the background in the first slide.

2. Create a one line text frame with the title of this slide “GATHERING INFORMATION”
in bold normal font.

3. Create a larger multiple line text frame under the title with the following messages inserted:
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Prepare an outline of your topic.

Decide how many slides will be required.
Keep each slide simple - one topic.

Prepare all the slides with information inserted.

We already know how to do these steps so this slide practices our skills. When the larger
text frame is selected, choose the Format Menu and choose the Border option to place
a border around the text frame.

Slide 3 - Adding Special Effects

Insert a new slide from the Insert Menu and place a text frame on the slide. Type the
title “ADDING SPECIAL EFFECTS” on this frame. Add another multiple line text frame with
the following contents.

Clip Art

Background and Borders
Adding a Command Button
Scripting Any Object

Now let's insert a clip art picture over part of the text box you previously entered. If you
click on the Clip Art and then click on the Format Menu, you can send the clip art to
the back or click on the text box to bring the text to the front. Use the Clip Art Drawing
tool to create special clip art for your reports. When inserting your created clip art choose
MORE from the Clip art dialogue box and then go to your directory to select your file.

A powerful addition to the Report Writer is the ability to insert a command button. A command
button can be programmed to play special effects(SFX), play a music file created in the
Melody Maker or go to (GOTQO) another slide in the presentation. Double clicking on any
clip art or text object can also open the programming dialogue box to play music. You
can choose the SCRIPT icon from the Edit Menu to accomplish the same goal. Music,
special effects and jumping between slides add life to a presentation and make it more
interesting.

Slide 4 - Presenting the Show

Insert the fourth slide from the Insert Menu and place a large title bar with “PRESENTING
THE SHOW'" across the top of the slide. The multiple line text box underneath would contain
the following:

Show
Setup

Setup is the second icon under the View Menu. Setup allows you to choose between an
automatic slide with built-in timings or a manual presentation that advances when the mouse
is clicked. Choose automatic timings and set a time for each slide to appear. Choose manual
if you want to talk as the show progresses. After Setup, select the Show icon in the View
Menu and watch the slides appear. If you chose automatic timing then only the pause button
and the stop button will appear on the screen.
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If you chose the manual presentation mode then you can control the progress of the show
by clicking on the arrow.

Remember when working on a presentation to save your work. Preparing a great presentation
report takes time and careful thought, but the results are more than worthwhile. Just plug
your presentation into a large screen TV to see some spectacular results!

CHAPTER 23 SPELL CHECKER

If you don't know how to spell a word it is possible to check the spelling by using the
Spell Checker application. There is no need to start the word processing application if
you only wish to check a single word.

HOW TO BEGIN

Doubile click the SPELL CHECKER icon Q on the Desktop. A pop-up window will appear,
type in the word you want to check and click “Yes”.

If the Spell Checker cannot match the word that you typed, it will give you a list of
suggestions. If “More” appears in the dialogue box it means there are more suggestions
available for the word. Scroll down to see the additional options.

If the word you typed in does match a word in the computer’s dictionary, the word “Correct”
will appear in the suggestion box.

72

Downloaded from www.Manualslib.com manuals search engine


http://www.manualslib.com/

MENU BAR

File Menu @

There are two icons under the File Menu: Spell Checker and Exit. To exit the Spell Checker
you must close the pop-up window first by clicking the Cancel button. Then open the File
Menu and click the EXIT icon.

If you have already closed the pop-up window of the Spell Checker and you want to check
another word, just click on the Spell Checker icon to start again.

Help Menu

Click this icon to get additional information if you need guidance when using the program.

CHAPTER 24 SPREADSHEET

Spreadsheets are easy to understand. Imagine a calculator, a pencil, a piece of paper with
columns and rows neatly laid out. Now imagine this on a computer where all calculations
are done automatically and accurately.

Spreadsheets include extensive graphing functions to visually present the rows and columns
of numbers in ways that help clarify their meaning. To explain spreadsheets better, this
manual will take you through a Tutorial to show how different features work.

HOW TO BEGIN

Double click the SPREADSHEET icon % on the Desktop. You should see a Menu

Bar and a grid with A-E across the top and 1-6 down the left side. If this is your first
time using a spreadsheet, the Tutorial below will be helpful to you.
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TUTORIAL

Stamp Collecting

Stamp collecting is a popular hobby. Not only are stamps interesting and beautiful, but they
can also increase in value over time. A spreadsheet can help you keep track of the value
of certain stamps as well as the value of your whole collection.

The Spreadsheet Screen

If you are new to spreadsheets the screen may seem a bit confusing with all the letters,
numbers, lines and codes. There is no need to be concerned. Let's take a closer look.

At the top of the screen is the familiar Menu Bar.

The white part of the screen is the main worksheet area. Rows (horizontal) are identified
with numbers and columns (vertical) are identified with letters. Where a row and column
meet is called a cell. All information is entered in cells. A cell is referred to by its column/
row identifier, i.e. A4. The area to the left of the “OK” box near the top of the screen shows
cell name of the current cursor location. The area to the right of the “OK” box shows
the actual contents of the cell. The actual contents of a cell is not necessarily what you
see in the cell itself. For example the area to the right of the “OK” box may show an
equation. The actual cell would show the result of the equation.

The scroll bars on the right and bottom of the screen allow you to scroll to any of the
26 row or 26 column positions on the screen. To the left of the horizontal scroll bar is
a special box for switching between the Chart and the sheet.

The bottom line of the screen has status indicators for auto calculation, INSert, CapslLock,
and NumLock.

Designing the Spreadsheet

Designing a spreadsheet involves deciding what information you want to analyze. A
spreadsheet is basically a blank form that stores and calculates information. You must provide
the design and gather the data. In general, the more you prepare for data entry, the better
your spreadsheet will function.

For our tutorial, let's keep track of some information about our stamp collection.

Country Country of origin of the stamp

Year Year the stamp was published

Condition E - Excellent, VG - Very Good, G - Good or P - Poor
Date Date you acquired the stamp

Cost Price you paid for the stamp

Value Current value

Profit Value - Cost = Profit if you sold today

There are two kinds of information you can enter into a spreadsheet.
Labels - Column and Row identifiers to indicate what the numbers mean.
Values - Numbers and formulas.
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Changing Column Width

Labels usually go at the top of the columns of your spreadsheet. When this is done, they
are also called Titles. Go to cell A1 and type in “Country” then press ENTER. The spreadsheet
defaults to a 5 character column width so “Country” appears in the cell as #####. To make
the column wider choose the COLUMN WIDTH icon from the Format Menu. When the
pop-up screen appears, change the width to 15. That should cover the names of most
countries.

Now make column B wider and enter “Year” into it. Continue entering labels and widening
columns until all titles (Country - Profit) are entered. You do not need to make all columns
15 spaces wide, this is a waste of memory. Only make the cclumns as wide as you will
need them to be.

Centering Titles in a Column

After the titles of the columns are entered you might want to center the titles in each column.
First, click on the number 1 in the leftmost column. This selects the entire row of column
headings. To show that it is selected the entire row will be highlighted in black. Second,
open the Font Menu and the select the CENTER JUSTIFY icon . This will justify each

title across its column.

Entering Data

The next step is to enter the information into the spreadsheet. This involves some typing.
Use the data below to get started. Make sure the light grey box is around the cell where
you want to enter the information.

To enter data, move the grey box to the cell in which you want the data entered. Type
the data and then select the “OK” button on the screen | or press ENTER on the
keyboard. When you press ENTER, the cursor will automatically move down one row.
This is the application assuming you will enter data from top to bottom. |If you do not
want to add data to that cell, move the cursor to the cell you want to add data to. If the
column is not wide enough, the ##### markers will appear in the cell.
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Fill in all the columns except the Profit Column. We will let the spreadsheet do the Profit

calculations.
A B C D E F G
1 Country Year Condition Date Cost Value Profit
2 Britain 1945 G 10/10/95 5.00 10.00
3 Kenya 1975 VG 9/9/94 .30 .60
4 China 1987 E 8/8/95 .20 .20
5 | Yugoslavia 1991 E 7/7/95 .50 3.00
6 India 1982 VG 6/6/94 .25 .30
7 | Hong Kong 1996 E 5/5/96 .80 1.00
8 Germany 1985 P 4/4/93 .25 25
9 Britain 1982 E 3/3/94 .50 .60
10 | United States | 1979 E 2/2/94 1.00 2.00

Formatting Currency Information

In this spreadsheet we assumed the currency was in U.S. dollars. The information you
entered in Columns A-D was simply text data, but the Cost and Value columns are number
values that we are going to use in our calculations. The Cost and Value columns contain
currency and need to be formatted as currency. Click on the “E” above “Cost” to highlight
the entire column. Open the Format Menu and select the CELL icon.

From the pop-up window select the “Currency” option and click “Yes”. Do the same with
column F and column G.

Entering Formulas

Formulas allow you to perform calculations on the numeric data in your spreadsheet.
Formulas are very helpful because if you change a data value, the formula will automatically
recalculate based on the new value. Go to G2 and type the following formula “=F2-E2”.
In English this means, “Take the value of cell F2, and subtract the value of cell E2 and
place the result in G2." This calculation tells us the profit number we were looking for.
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Copying or Replicating Formulas

One of the most used and powerful features of a spreadsheet is the ability to take a formula
and copy it into a new cell relying on the computer to update the cell names in the formula.
For example, if we copied the formula in G2 to G3 the computer would change the equation
to read “=F3-E3.” To copy a formula:

Highlight the cell to be copied.

Select the COPY icon from the Edit Menu.

Move the grey box to the cell where the formula is to be copied.
Select the PASTE icon from the Edit Menu.

Copying a formula places it in the clipboard memory. Once the formula is in the clipboard
memory, you do not need to copy it again. Just point to each of the cells in Column
G where you want the formula and select PASTE.

Summation Function

Spreadsheets contain a number of standard mathematical functions to make calculations
easier. For example, to add all the values in the cells in Column E, go to cell E11. Type
in the formula “=SUM(E2:E10)" and press ENTER. All the numbers in the column will be
added together giving you the total value of your collection. To experiment with this concept,
go back and change one of the costs and watch how the Sum in cell E11 changes. When
you are confident with the Summation Function total columns F and G.

Another way to choose one of the math functions is to select the Data Menu and choose
f(x). This stands for math functions. Use the arrows to scroll to SUM. This will cause =SUM
to appear in the edit space to the right of the grey “OK”. Just complete the line with
the correct cell references and press ENTER.

To indicate that the new numbers are Totals, label the row. Go to cell A11 and type “Totals”.
With that your spreadsheet is complete.

Saving Your Work

Always save often and save early. From the File Menu select the SAVE icon. Choose
a folder for your work and then type in the name of a file. Choose a few letters that will
make it easy for you to remember the file. For instance, “STAMP” would be a good name
for the stamp collection spreadsheet.

Creating a Chart

The PRECOMPUTER UNLIMITED™ has the ability to make charts or graphs of the data
in a spreadsheet. Making a chart involves 4 steps. To begin, select the CREAT CHART
icon from the Data Menu.

1. Choose the type of chart - Line, Bar or Pie.

2. Choose the row and column of numbers to chart. For our example if you wanted to
graph column G you would select cells G2-G10.
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3. Choose the X Label range. The X Label range for our example would be the country
names, or A2-A10.

4. Finally enter a name for the chart, for example, Stamp Collection.

After following these steps, your chart should appear. You can always go back and
change chart variables if you would like a different chart setup.

Additional Features

Spreadsheets do not usually fit entirely on the screen. You can keep important labels on
the screen by “freezing” the row or column of labels. Select the row or column you want
to freeze then select the FREEZE icon from the Windows Menu.

Use the Insert Menu to insert rows or columns. Do this by selecting the row or column
that would be after the new row or column to be inserted. Then open the Insert Menu
and select either the ROW or COLUMN icon.

You can delete rows or columns from the Format Menu.
To change a font open the Fonts Menu and click on the icon of the font you want.

Placing borders around a spreadsheet can make it easier to read when printed. This option
is available in the Windows Menu.

CHAPTER 25 TEST TRAINER

The Test Trainer application allows you to input matching information and have the unit
test you. This will be helpful if you are trying to learn a list of words, equations, or even
chemical symbols. Since you can input any information you want, the uses are unlimited.

HOW TO BEGIN

To use the Test Trainer double click the TEST TRAINER icon W&l on the Desktop.
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MENU BAR

File Menu E i’

This menu works as described in the Chapter 5 (HOW TO BEGIN) of the manual. Please
refer to that part for details.

Data Menu |~ ||[[° |

Inputting Data

When you entering this activity you will need to input your data first. Type in the first
part of the word or phrase that you want to be tested on in the section marked “Original”,
then press ENTER. Next type information you want linked to the “Original” in the section
marked “Corresponding” and press ENTER. For example, you could input “Hello” in Original
then type “Hola” in Corresponding if you were studying Spanish.

You have now inputted the first set of data. The unit will return to the Original section
for you to enter the second set. Continue this process until you have entered your entire
list.

and

If you inputted more than one data, you can use the
Page Down keys to see the previous and next data.

Editing Data

First, find the record you want to edit. Then go to the Data Menu and select the EDIT
icon. You can edit your entry by typing over the existing information. When you have
finished, press the ENTER key to confirm the change.

Choose this icon when you want to find a record to review, delete, or edit. The unit will
only search for the words or phrases which have been entered in the Original section.
Select the Search icon and type in the word or phrase you want to find. Press ENTER.
If the unit locates the record it will display it on the screen. If the record cannot be found,
the unit will display the first record in your list.

Add

Choose this icon when you want to add more data to an existing list. All new entries will
be added to the end of the list.
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Delete

Choose this icon when you want to delete a record from an existing list. Before you choose
this icon be sure that you are on the record you want to delete. You will not be able
to retrieve the information once it has been deleted.

Test Menu

When you have entered all of your information click this icon to have the unit begin testing
you on the data. There are two different ways to be tested:

Original

The unit will show you the word or phrase you typed in the Original section. You need
to supply the contents of the Corresponding section. And then press ENTER to confirm.

Corresponding

The unit will show you the corresponding word or phrase, you need to type in the correct
Original word or phrase and then press ENTER to confirm.

ar ‘ ‘}J

[

Player Menu

This activity allows for 2 modes of play - 1-player and 2-player. In the 1-player game
there are 3 chances for you to answer the question. In each chance, you have 1 minute.
if you give a wrong answer or run out of time, you will lose 1 chance. When aII three
chances for a question are gone a new question will appear. If you use the |8
no points will be awarded. At the end of each round you will be asked if you ‘want to
continue.

In 2-player mode, the player who presses histher Player key first earns the right to try
to answer the question first. If the first player fails to give a correct answer, the second

player gets a turn to try. The second player can answer the question or click the [§

button to skip the question. When a round is finished, the player with the higher score
wins. |If the players have the same score, the game is a draw.

Option Menu f‘l)J

This is where you can turn the sound on or off. Open the Option Menu then select the
appropriate icon.
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Help Menu

If you are confused open the Help Menu for a list of terms which apply to the Test Trainer

activity.

Scoring

1-Player Mode

Questions per round 5
Correct answer on the 1st try 20
Correct answer on the 2nd try 10
Correct answer on the 3rd try 5

2-Player Mode

Questions per round 5
Starting Score 100
Correct answer

1st player 20
2nd player 10
Wrong answer

1st player -20
2nd player -10

CHAPTER 26 TRIVIA

There are 3 trivia topics built into the PRECOMPUTER UNLIMITED™. The topics are:
Dinosaurs, Marine Life, and Space.

How to Begin

Double click any of the trivia icons on the Desktop. A message will appear telling you
to begin. Each round consists of 10 questions. All questions are multiple choice. Answer
by clicking the correct answer with the mouse or selecting the correct key on the keyboard.

MENU BAR
o[

This menu functions as described in the Chapter 5 (HOW TO BEGIN) of this manual. Please
refer to that area for details.

File Menu
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Level Icon

Each trivia topic has 4 levels of challenge. To change the level at any time open the
Level icon and select the icon (1-4) which corresponds to the level you desire.

Player Icon

This activity allows for 2 modes of play - 1-player and 2-player. In the 1-player mode
you have 10 seconds and 1 chance to select the correct answer for each question. After
each question you will receive an animation. If you need a hint to answer a question,
click on one of the blue Hint icons located in the lower right hand corner of the screen.
You get 3 Hint icons per round. After a round of questions you will be asked if you want
to continue. If you answer 7 questions in a round correctly you will be promoted to the
next level.

To access the 2-player mode, open the Player Menu and click on the 2-player icon. The
unit will then ask you to enter a name for each player. Enter your name by typing it on
the keyboard then clicking the “Yes” button on the screen. In 2-player mode, the players
take turns answering questions, with player 1 going first. When a round is finished, the
player with more colored blocks wins. If the players have the same number of blocks,
the game is a draw.

Option Menu !77;

This is where you can turn the sound effects and music on or off. Open the Option Menu
then select the appropriate icon.

Help Menu wr I ‘H|

If you are confused open the Help Menu for a list of terms which apply to the trivia activities.

Scoring

In this activity the score is not kept in points. Rather for each correct answer a player
is awarded a colored block. The colored blocks build-up in your player bin until the round
is over. You start building a new set of blocks with each new round of questions.

CHAPTER 27 TYPING TUTOR

The Typing Tutor application teaches a crucial skill to any computer user. Improving your
keyboard technique is essential for gaining the most from your computer. It is especially
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useful to have good keyboard skills when using the computer for homework preparation.
Using computers is becoming more and more acceptable and expected for school work.

HOW TO BEGIN

>

First select the Typing Tutor icon from the desktop. A keyboard and typing screen

will appear with a dialogue box which says “Ready to Start!”. When you are ready to
begin click “OK”. The letters and symbols you need to type will then appear on the screen.

HOW TO CONTINUE AFTER YOU HAVE FINISHED
AN EXERCISE

When you're finished an exercise the application will stop and give you an accuracy reading.
Next you will see a brief animation. Then the unit will ask you if you would like to save
your record (see Status File below).

If you click “Yes” at the save screen you will go to the folder to save your file. If you
reach 80% accuracy, the next screen will ask you if you would like to advance to a new
level. Click “Yes” to move up one level; click “Cancel” to remain at the current level. After
you'd saved the file, if you did not reach 80% accuracy, you will be asked if you would
like to try again at the same level. Click “OK” to continue.

If you click “Cance!” at the save screen the unit will automatically look at your accuracy
reading. If your accuracy is 80% or above, the unit will ask you if you would like to try
another level. Click “Yes” to advance one level. If your accuracy reading was below 80%,
the unit will ask you if you would like to try again at the same level. Click “OK” to continue.

If you become interrupted during the middle of a typing session and would like to begin
again, go to the File Menu and click “New".

Levels
There are six levels representing six different areas on the keyboard. The levels are detailed
as follows:

Level 1 Home Row

Level 2 Third Row + Home Row

Level 3 Third Row + Home Row + SHIFT
Level 4 Add the First Row

Level 5 Add the Numbers and Symbols

Level 6 Summary of All Keys

The Typing Tutor has a full keyboard on-screen which means you don't have to look at
the keyboard when typing. As you become proficient as a typist, you will learn where
all the keys are and will no longer need to see the keyboard.
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The Typing Tutor will always start at level 1, but you can change the level once the game
has started. To change the level go to the Level menu and choose the level you prefer
(see above for the content of each of the levels).

Feedback

If you miss a letter, you will hear a sound effect and the incorrect letter will appear on
the screen in red instead of blue. Your goal is to reach an accuracy level of over 80%.
There is no time limit on the exercise, but your time will be recorded and used to caiculate
your words per minute (WPM). The accuracy level and WPM will be displayed in the bottom
left hand corner of the screen. The percent of the exercise completed is displayed at the
bottom right of the screen. The timer will be shown in the top right hand corner of the
screen, in the text box.

Status File

The Typing Tutor has an excellent feature which allows you to keep a record of your progress,
it is called a Status File. After you have completed each level you will be asked if you
want to save your status. The Status File will record your accuracy and words per minute
(WPM). If you do not save the status then the results will not be recorded. Results can
be saved for each level. The current status can be viewed by choosing the VIEW icon
under the Status Menu. A complete record of accuracy and WPM wili appear on the screen
for each level.

Level 1121345386
Accuracy
WPH

Options

Using the Option Menu you can turn the music off or on. Sometimes the music can distract
you from your typing but at other times it can be an encouragement. The same is true
of the sound effects. The Option Menu allows you to turn the music and sound effects
off and on.

Help

As always, the Help Menu reviews the operational details of the program should you have
any questions.

The important thing to remember when using Typing Tutor is that you need to practice
regularly until you no longer have to look at the keyboard to type with speed and accuracy.
Just 10 minutes a day for a few weeks will result in a dramatic improvement in your typing
skills. Keep with it and don't give up until you become a master at Typing Tutor.
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CHAPTER 28 WORD PROCESSING

The Word Processing application in the PRECOMPUTER UNLIMITED™ is a valuable tool.
Not only does it allow you to write reports, letters, and lists but you also get the advantages
of saving your work and having the computer speill check your documents.

HOW TO BEGIN

Double click the WORD PROCESSING icon

opens you will see the Menu Bar across the top of the screen and a large, white working
space covering the rest of the screen. This white space is where any text you type will
appear.

on the Desktop. When the application

If this is your first time using a word processor, the tutorial below will be helpful to you.

TUTORIAL

This tutorial will teach you how to write a letter in Word Processing application. If you
make any mistakes, move the cursor to the area just to the right of the mistake. Next
press the Backspace key on the keyboard to erase the mistake one letter at a time. You
can then retype the incorrect word correctly. Note that you don’t need to press ENTER
at the end of every line. This feature is called automatic wordwrap. Type the following
into white work space:

Dear Jim,

We so enjoyed your last letter about your trip to Hawaii and all the activities you enjoyed in
the sun. Dad and I are anxious to hear more about your in-line skating and the easy life on
the beach. Did you get 1o travel much to the other islands?

The next time you are near Pittshurgh please drop by. We could play some ball and have a
barbecue in the backyard.

Your friend,

Sam

That's all there is to it! You have created your first word processing document. Read
through the Menu Bar instructions below to learn how you can perform more advanced
functions of this useful application.

MENU BAR

File Menu

All options available in the File Menu are explained in the Chapter 5 (HOW TO BEGIN)
of this manual. Please refer to that parn for details.
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Note: When working in the Word Processing application, save your work frequently.
Frequent saving is a good habit to get into whenever using a computer. Save
your letter to Jim now.

Edit Menu [.“/ ‘

C

The Edit menu has several menu options. As you write longer documents these functions
will become quite useful to you.

Block Editing

Block Editing allows you to Cut, Copy, and Paste entire sections of your document. This
is used when you want to reorder entire paragraphs or when you want to delete large
sections of text. Using the example letter we wrote to Jim, follow these steps to cut and
paste a block of text:

Click on the Edit Menu and choose the first option - BLOCK.

Place the cursor at the beginning of the second paragraph and click the mouse.
The first letter of the block becomes highlighted.

Move the cursor where you want the block to end and click the mouse.

Now the entire block is highlighted.

Select the CUT icon from the Edit Menu. The block disappears to the clipboard memory.
Move the cursor to the top of the letter, below “Jim” but above “We”.

Select the PASTE icon from the Edit Menu.

The block shifts from clipboard memory back to your document, but in a new location.

© ® N O~ v~

It is possible to Copy a block of text in the same manner. However, when copying, the
text does not disappear from your document when it moves to the clipboard. Instead, a
copy is saved to the clipboard. This way you can paste the text as many times as you
wish in different locations.

Always save your work after extensive block editing. If you are not sure your changes
should remain then you might decide to save the work with a new file name. Select Save
As from the File Menu. Repeat the saving sequence again with a new file name.

Find and Replace

The Find feature helps locate words for editing while the Replace feature locates words
and allows you to replace them with a new word. This feature is really helpful when you
use a name again and again and find out later it is misspelled. Using our sample letter
above, suppose you wanted to change the “Pittsburgh” to “Orlando”. In a longer document
it would make sense to follow the Replace procedure. Here are the steps you would follow:
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. Select the REPLACE icon from the Edit Menu.

Enter “Pittsburgh” in the "Find" section of the pop-up window.

Click on the ‘Replace’ section and type-in “Orlando”.

The computer will go to the first appearance of the word “Pittsburgh” and highlight it.
A new dialogue box will ask you if you want to replace the highlighted word.

Click “Yes” to replace “Pittsburgh” with “Orlando”

N o O & w

The computer will then move on to find the next occurrence of Pittsburgh until the entire
document has been checked.

insert Menu

The following are the special items that can be inserted into your document.
Date

Put the cursor above “Dear Jim” in the sample letter. Open the Insert Menu and select
the DATE icon. The computer will automatically insert the date into the letter. Note: Be
sure to enter the correct date in the Date/Time setup located in the Control Panel, or the
correct date will not appear in your letter.

Header

A Header is a block of text that appears on the top of every page as each page is printed.
Using a Header can make your life easier if your document contains certain information
which is needed over and over again, for instance your name and your teacher’s name
on every page of work handed in. This can be placed in a header. To make a Header
open the Insert Menu and select the HEADER icon. In the pop-up window type the
information you would like to appear. When you are finished click “OK”. Headers should
not be very long.

Footer

Footers work just like Headers but they appear on the bottom of the page. They don't
appear on your work space but do appear in the printed page and on the preview page.

Page No. - The Page No. feature is just a special form of footer. If you activate this feature,
a page number will automatically be added to each page. When you click the PAGE NO.
icon a dialogue box will ask you whether the number should be on the left, middle, or
right of the bottom of the page.

Clip Art

The clip art library of the PRECOMPUTER UNLIMITED™ is available in the Word Processing
application. Open the Insert Menu and select the CLIP ART icon. Use the scroll bar to
highlight the name of the picture you want to insert then click “Yes”. While the graphic
does not appear in the work space, the computer puts a marker in the text to show you
where the picture will appear when you print your document. Be sure to leave ample room
for each graphic, some pictures are large and cannot be re-sized. Go to the Art Studio
and open the same graphic to see how big it will be in your document. The Clip Art Drawing
program allows you to design your own clip art for your work. One suggestion is to save
your creations to a special folder for use whenever needed.
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Page Break - The Word Processing automatically breaks pages according to the characteristics
of your printer, usually around 60 lines per page. However, you can easily “force” a page
break by inserting one. Place the cursor where you want the new page to start, go to
the Insert Menu and choose the PAGE BREAK icon. A dotted line will indicate where
the page break occurs.

' ‘M 1

Format Menu [“ ]

Formatting helps you determine how your document will look on paper. The following are
the Format options:

Margin

Margins are the blank areas on the borders of a document surrounding the text. By adjusting
the borders you can squeeze your text to the center of the page or expand it all the way
across a sheet of paper. Standard margins for US term papers is 1 inch of margin on
all sides (top, bottom, left, and right). To adjust the margins open the Format Menu and
select the MARGINS icon. Enter the new margin data then click “OK". It is best to set
the margins of a document before you begin typing. You do not need to adjust the margins
if you do not want to, the application has a margin default setting installed.

Tab

This tool sets the number of spaces indented when the TAB key on the keyboard is pressed.
A standard US tab is 5 spaces. You do not need to adjust the tab settings if you do not
want to, the application has a tab default setting installed.

Line Spacing

This tool lets you control the amount of space inserted between lines of text each time
a new line begins. Go to the Format Menu and select the LINE SPACING icon. Select
the line spacing option you desire and click “Yes”. Many teachers prefer the double spacing
option for homework documents. This leaves room between the lines for teachers to write
their comments.

Justification is the alignment of words on the edges of the page, where the words meet
the margins. All of these options are available in the Format Menu.

Left Justify

This is the normal or default setting. When a document is Left Justified all the words
on the left hand side of the page will line up directly under one another. If a document
is Left Justified words on the right hand side of the page will not align directly under each
other leaving a jagged look to the text.

Right Justify

The right hand side of the text is aligned but the left is not. This is useful when writing
dates, addresses or class report headlines that need to appear on the right hand side of
the page.

Center Justify
When you select this option all text will center on the page. This means that both sides
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might be jagged. This is not a normal way to write a document, but the option is frequently
used when putting a title on the top of a page.

Justify

This option inserts extra spaces between words so that both the left and right hand margins
are straight. This is the normal appearance of text in books.

~
Font refers to the size and style of the text you are typing. You can adjust font types
throughout your document to add special emphasis to certain words, or you can change
a font just because you have a stylistic preference. To change from the default font, open
the Font Menu and select a new font from the choices given. As you move the cursor
to each font icon, a description of the font appears in the text box in the upper right hand

corner of the screen. When a new font is chosen all text from that point on assumes
the new font.

Fonts Menu

View Menu E

The View Menu allows you to view your document as it will appear on paper. Think of
this as a print preview. You must return to the normal view to do editing.

Tool Menu

The tool for the Word Processing application is the Spell Check. After you click on the
SPELL CHECK icon, you will be asked if you want to check the whole document (ALL)
or just one word. If you have written an entire document you should choose the ALL option.
If you select the single word option you must type in the word you want the computer
to look for then click “OK”.

The Spell Checker works by comparing every word in your document to all the words in
its dictionary. If it finds a match it assumes the word is correct and moves on to the
next word. If the Spell Checker finds a word in your document which does not match
any word in its dictionary it will stop and give you a list of possible aiternative words with
similar spellings. At this point you can decide to ignore the unit's suggestions or replace
the suspect word with one of words from the unit’s list, or type in a new word to replace
the suspect word. You can exit the Spell Checker at any time by clicking "Cancel" on
the screen.

Help Menu b_] L”_;

Select the HELP icon for a list of topics pertaining to the Word Processing application.
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CHAPTER 29 WORD PUZZLE

Word Puzzles are fun ways to learn new facts and solve riddles.

HOW TO BEGIN

A hard crystalline carbon,

Double click the WORD PUZZLE icon @B on the Desktop. You will see a puzzle with

10 blank spaces. One space is already highlighted, but you can use the cursor to point
to a different blank if you would like to begin elsewhere in the puzzie. Each time you
select a blank the ctue which will help you fill in the blank will appear on the right hand
side of the screen.

MENU BAR

File Menu

This menu functions as described in the Chapter 5 (HOW TO BEGIN) of this manual. Please
refer to that part for details.

—
Level Menu

This activity allows for 4 levels of challenge. To change the level at any time open the
Level Menu and select the icon (1-4) [zl =el: 81 -8 which corresponds to the level you desire.
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8| and 2-player [@] . in the 1-player
mode you have 5 minutes and 4 chances to finish the puzzle. To enter a word click on
the blank, read the clue, then type in your answer and press ENTER. If you are correct
the word will appear in the blank. If you are incorrect any correct letters will remain on-
screen, but you will not get any points until the entire word is entered correctly. Chances
are used by inputting an incorrect answer, pressing the Hint icon (gives you a free letter),
or pressing the Answer icon (gives complete answer to the current blank). The puzzle
is over when you correctly solve all the blanks, you run out of time, or you run out of
chances.

At the end of each puzzle you will be asked if you want to continue. If you earn perfect
scores in two consecutive puzzles, you will be promoted to the next level of difficulty.

You can access the 2-player mode by opening the Player Menu and clicking on the 2-
player icon [#] . In 2-player mode, the players take turns trying to fill in the blanks. Stating

with Player on each person has 30 seconds to fill-in as many blanks as possible. The
turn switches when a player enters a wrong word or the 30 seconds is up. If at any
time neither player can solve the remaining blanks, the players can agree to press the
Answer icon. This will reveal the answers to all the blank questions remaining in the puzzle.

When a round is finished, the player with the higher score wins. If the players have the
same score, the game is a draw.

[B{f hard crystaline

Option Menu

This is where you can turn the sound or music on or off. Open the Option Menu then
select the appropriate icon.
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Help Menu ]

If you are confused open the Help Menu for a list of terms which apply to the Word Puzzle
activity.

Scoring

In both 1-player and 2 player modes each correct answer is worth 10 points.

CHAPTER 30 WORD ZAP

Word Zap is an activity which lets you to practice your keyboarding technique. In Word
Zap you need to imagine that there is a virus attacking your computer. The virus takes
the form of the letters, symbols, and words falling from the top of the screen. Your job
is to clean the screen of the viruses before they hit the memory tanks located at the bottom
of the screen. If the virus eats all your memory then the game is over.

HOW TO BEGIN

from the deskiop. You will see a green background

First select the Word Zap icon f

screen with black memory tanks at the bottom. Next a dialogue box which says “Ready
to Start!” will appear. When you are ready to begin click “OK”. The letters and symbols
you need to type will then begin appearing on the screen. Type each letter before it hits
the memory tanks. Each time a tank is hit a section of it will turn red. An all red memory
tank is completely destroyed.

HOW TO CONTINUE AFTER YOU HAVE FINISHED
A LEVEL

When you're finished a level the application will stop and ask you if you would like to move
to another level. If you click “Yes” the unit will automatically promote you to the next level.
If you click “Cancel” you will return to the current level.

Levels

There are six levels in the game representing six different areas on the keyboard.
Level 1 Home Row
Level 2 Third Row + Home Row

Level 3 Third Row + Home Row + SHIFT
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